# CVE-2026-56701: Grav - XML External Entity Injection via SVG Upload

> Authenticated attackers can read arbitrary files via XXE injection in SVG uploads due to unsafe XML parsing in Grav CMS.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-3446-6mgw-f79p

## What is CVE-2026-56701?

CVE-2026-56701 is a high-severity vulnerability in Grav, published on 23 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Grav before 2.0.0-beta.2 contains an XML external entity injection vulnerability in SVG file upload processing that allows authenticated attackers to read arbitrary files. The application uses simplexml_load_string without disabling external entity loading, enabling attackers to inject XXE payloads via malicious SVG files to exfiltrate sensitive data.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2026-56701?

2 open source packages ship an affected version, including getgrav/grav.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 2.0.0-beta.2 |
| `getgrav/grav` | Packagist | All versions | 2.0.0-beta.2 |

## How do I fix CVE-2026-56701?

Upgrade getgrav/grav to 2.0.0-beta.2 or later.

## Is CVE-2026-56701 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56701 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56701 and fix it if it is affected.

What it is: CVE-2026-56701 is a high-severity vulnerability in Grav, published on 23 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56701 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.0-beta.2
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.0-beta.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56701/ (Markdown: https://insights.sbomify.com/CVE-2026-56701/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56701
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56701
- OSV: https://osv.dev/vulnerability/CVE-2026-56701

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56701/
Summaries are generated and may contain mistakes; the official description above is the record.
