# CVE-2026-56725: Zammad: Denial of Service via OTRS Import Controller

> Unauthenticated attackers can cause denial of service in Zammad by sending requests to an unprotected import endpoint that blocks server workers.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** GHSA-45cx-9mrq-mmcj

## What is CVE-2026-56725?

CVE-2026-56725 is a high-severity denial of service vulnerability in zammad, published on 25 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Zammad is a web based open source helpdesk/customer support system. Prior to 7.0.2, summary An unauthenticated request to POST /api/v1/import/otrs/import_check blocks a Zammad request worker for roughly two minutes. The import_check and import_status actions are missing the setup_done_response guard that other actions in the same controller carry, so they execute on fully set-up production instances. The action enters a retry loop against a blank OTRS endpoint, sleeping for 30 s + 45 s between attempts. Impact An unauthenticated remote attacker denies service to a production Zammad instance. Each request costs almost nothing and forces ~115 seconds of server-side blocking. A few requests per second saturate the Puma worker pool. The condition persists as long as the traffic continues. No account, valid import configuration, or target knowledge beyond the hostname is needed. CSRF token is trivially obtained from any prior GET response. This issue is fixed in version 7.0.2.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-56725?


## How do I fix CVE-2026-56725?

No fix has been published for CVE-2026-56725 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-56725 being exploited?

There is no known exploitation of CVE-2026-56725 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56725 and fix it if it is affected.

What it is: CVE-2026-56725 is a high-severity denial of service vulnerability in zammad, published on 25 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-56725 in the wild and no public exploit code.

Affected product: zammad. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56725/ (Markdown: https://insights.sbomify.com/CVE-2026-56725/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56725
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56725
- OSV: https://osv.dev/vulnerability/CVE-2026-56725

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56725/
Summaries are generated and may contain mistakes; the official description above is the record.
