# CVE-2026-56727: Zammad: PGP signature spoofing via unvalidated verification return

> Attackers can spoof PGP signatures in Zammad emails by exploiting unvalidated verification returns, misleading users into trusting forged content.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 25 Sep 2026
- **Updated:** 25 Sep 2026
- **Also known as:** GHSA-56jc-34c8-2xq4

## What is CVE-2026-56727?

CVE-2026-56727 is a high-severity vulnerability in zammad, published on 25 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Zammad is a web based open source helpdesk/customer support system. Prior to 7.0.2, summary In Zammad's inbound PGP email processing, the return value of the gpg verification call was silently discarded. Regardless of whether gpg reported a valid, invalid, or missing signature, the handler unconditionally wrote sign: { success: true, comment: "Good signature" } to the article's security preferences. Impact Any sender could tamper with the body of a multipart/signed PGP email, or craft a message with an entirely fabricated or mismatched signature, and Zammad would display it to the recipient as cryptographically verified with a "Good signature" label. Users and agents relying on Zammad's signature indicator to confirm message authenticity and integrity would be misled into trusting modified or forged content. The vulnerability affects all inbound PGP-signed emails processed while the PGP integration is enabled. This issue is fixed in version 7.0.2.

Weakness: CWE-391 (DEPRECATED: Unchecked Error Condition), CWE-347 (Improper Verification of Cryptographic Signature), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-56727?


## How do I fix CVE-2026-56727?

No fix has been published for CVE-2026-56727 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-56727 being exploited?

There is no known exploitation of CVE-2026-56727 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56727 and fix it if it is affected.

What it is: CVE-2026-56727 is a high-severity vulnerability in zammad, published on 25 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-56727 in the wild and no public exploit code.

Affected product: zammad. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56727/ (Markdown: https://insights.sbomify.com/CVE-2026-56727/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56727
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56727
- OSV: https://osv.dev/vulnerability/CVE-2026-56727

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56727/
Summaries are generated and may contain mistakes; the official description above is the record.
