# CVE-2026-56728: Zammad: Cross-User Taskbar Item Access Control Vulnerability

> An authenticated user can read another user's taskbar data, including ticket drafts, due to missing authorization checks in the GraphQL API.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Sep 2026
- **Updated:** 25 Sep 2026
- **Also known as:** GHSA-jvcg-5539-vvc3

## What is CVE-2026-56728?

CVE-2026-56728 is a medium-severity missing authorization vulnerability in zammad, published on 25 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Zammad is a web based open source helpdesk/customer support system. Prior to 7.0.2, a broken access control vulnerability exists in Zammad's GraphQL API. An authenticated user can access taskbar item data belonging to another user by crafting a request with the target user's taskbar identifier. The taskbar feature stores transient state for active user sessions, including auto-saved ticket drafts. Under certain conditions, the authorization check for taskbar item access is not enforced, allowing a user to read another user's taskbar item data. This vulnerability is fixed in 7.0.2.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-56728?


## How do I fix CVE-2026-56728?

No fix has been published for CVE-2026-56728 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-56728 being exploited?

There is no known exploitation of CVE-2026-56728 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56728 and fix it if it is affected.

What it is: CVE-2026-56728 is a medium-severity missing authorization vulnerability in zammad, published on 25 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-56728 in the wild and no public exploit code.

Affected product: zammad. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56728/ (Markdown: https://insights.sbomify.com/CVE-2026-56728/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56728
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56728
- OSV: https://osv.dev/vulnerability/CVE-2026-56728

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56728/
Summaries are generated and may contain mistakes; the official description above is the record.
