# CVE-2026-56730: Zammad: Missing authorization in GraphQL mutation for suggesting knowledge base answers

> An authenticated agent can read unauthorized knowledge base answers due to missing authorization checks in a GraphQL mutation.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 25 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** GHSA-pf47-8964-pp23

## What is CVE-2026-56730?

CVE-2026-56730 is a low-severity missing authorization vulnerability in zammad, published on 25 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Zammad is a web based open source helpdesk/customer support system. Prior to 7.0.2, an authorization bypass vulnerability was found that allows an authenticated agent to read knowledge base answer content they should not be able to access. The vulnerable GraphQL mutation is meant to transform a knowledge base answer suggestion so it can be inserted into the ticket editor, but it only checks if the user has the ticket.agent permission. Checking the authorization to the knowledge base answer itself is missing. This vulnerability is fixed in 7.0.2.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-56730?


## How do I fix CVE-2026-56730?

No fix has been published for CVE-2026-56730 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-56730 being exploited?

There is no known exploitation of CVE-2026-56730 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56730 and fix it if it is affected.

What it is: CVE-2026-56730 is a low-severity missing authorization vulnerability in zammad, published on 25 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-56730 in the wild and no public exploit code.

Affected product: zammad. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56730/ (Markdown: https://insights.sbomify.com/CVE-2026-56730/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56730
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56730
- OSV: https://osv.dev/vulnerability/CVE-2026-56730

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56730/
Summaries are generated and may contain mistakes; the official description above is the record.
