{"answers":{"affected":"4 open source packages ship an affected version, including thorsten/phpmyfaq and phpmyfaq/phpmyfaq.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56736 exists.","fix":"Upgrade thorsten/phpmyfaq to 4.2.0-alpha or later.","what":"CVE-2026-56736 is a high-severity cross-site scripting vulnerability in thorsten phpMyFAQ, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-56736 and fix it if it is affected.\n\nWhat it is: CVE-2026-56736 is a high-severity cross-site scripting vulnerability in thorsten phpMyFAQ, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56736 exists.\n\nAffected packages and fixed versions:\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.2.0-alpha\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.2.0-alpha\n- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.2.0-alpha\n- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.2.0-alpha\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-56736/ (Markdown: https://insights.sbomify.com/CVE-2026-56736/index.md)","id":"CVE-2026-56736","markdown":"https://insights.sbomify.com/CVE-2026-56736/index.md","name":"CVE-2026-56736","record":{"aliases":["GHSA-pgwp-vc7q-cvj3"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"phpMyFAQ web application","requires_auth":"none","summary":"Unauthenticated users can inject JavaScript via HTML entity bypass in FAQ submissions, leading to admin account takeover when administrators view the content.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"phpMyFAQ is an open source FAQ web application. A stored cross-site scripting (XSS) vulnerability in versions prior to 4.2.0-alpha allows any unauthenticated user (or low-privileged registered user) to inject arbitrary JavaScript that executes in an administrator's browser when they review or edit a user-submitted FAQ entry. This leads to admin account takeover via session theft. The vulnerability exists because `html_entity_decode()` converts HTML entities into executable HTML after `strip_tags()` has already passed them through, and the admin template renders the content with Twig's `|raw` filter without any output sanitization. Version 4.2.0-alpha fixes the issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"phpMyFAQ has Stored XSS in Admin FAQ Editor via HTML Entity Bypass in Frontend FAQ Submission","id":"CVE-2026-56736","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":4,"n_references":1,"next":{"headline":"phpMyFAQ's two-factor authentication login bypasses the password factor","id":"CVE-2026-56737"},"packages":[{"ecosystem":"Packagist","fixed":["4.2.0-alpha"],"introduced":["0"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":null,"source":"GHSA-pgwp-vc7q-cvj3"},{"ecosystem":"Packagist","fixed":["4.2.0-alpha"],"introduced":["0"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":"pkg:composer/phpmyfaq/phpmyfaq","source":"GHSA-pgwp-vc7q-cvj3"},{"ecosystem":"Packagist","fixed":["4.2.0-alpha"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":null,"source":"GHSA-pgwp-vc7q-cvj3"},{"ecosystem":"Packagist","fixed":["4.2.0-alpha"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":"pkg:composer/thorsten/phpmyfaq","source":"GHSA-pgwp-vc7q-cvj3"}],"prev":{"headline":"Zammad: Improper neutralization of `srcset` attribute in IMG tags in Zammad","id":"CVE-2026-56735"},"products":["phpMyFAQ"],"published":"2026-09-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-24","vendors":["thorsten"]},"summary":"Unauthenticated users can inject JavaScript via HTML entity bypass in FAQ submissions, leading to admin account takeover when administrators view the content.","url":"https://insights.sbomify.com/CVE-2026-56736/"}