# CVE-2026-56736: phpMyFAQ has Stored XSS in Admin FAQ Editor via HTML Entity Bypass in Frontend FAQ Submission

> Unauthenticated users can inject JavaScript via HTML entity bypass in FAQ submissions, leading to admin account takeover when administrators view the content.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** GHSA-pgwp-vc7q-cvj3

## What is CVE-2026-56736?

CVE-2026-56736 is a high-severity cross-site scripting vulnerability in thorsten phpMyFAQ, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

phpMyFAQ is an open source FAQ web application. A stored cross-site scripting (XSS) vulnerability in versions prior to 4.2.0-alpha allows any unauthenticated user (or low-privileged registered user) to inject arbitrary JavaScript that executes in an administrator's browser when they review or edit a user-submitted FAQ entry. This leads to admin account takeover via session theft. The vulnerability exists because `html_entity_decode()` converts HTML entities into executable HTML after `strip_tags()` has already passed them through, and the admin template renders the content with Twig's `|raw` filter without any output sanitization. Version 4.2.0-alpha fixes the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-56736?

4 open source packages ship an affected version, including thorsten/phpmyfaq and phpmyfaq/phpmyfaq.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thorsten/phpmyfaq` | Packagist | All versions | 4.2.0-alpha |
| `thorsten/phpmyfaq` | Packagist | All versions | 4.2.0-alpha |
| `phpmyfaq/phpmyfaq` | Packagist | All versions | 4.2.0-alpha |
| `phpmyfaq/phpmyfaq` | Packagist | All versions | 4.2.0-alpha |

## How do I fix CVE-2026-56736?

Upgrade thorsten/phpmyfaq to 4.2.0-alpha or later.

## Is CVE-2026-56736 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56736 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56736 and fix it if it is affected.

What it is: CVE-2026-56736 is a high-severity cross-site scripting vulnerability in thorsten phpMyFAQ, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56736 exists.

Affected packages and fixed versions:
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.2.0-alpha
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.2.0-alpha
- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.2.0-alpha
- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.2.0-alpha

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56736/ (Markdown: https://insights.sbomify.com/CVE-2026-56736/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56736
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56736
- OSV: https://osv.dev/vulnerability/CVE-2026-56736

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56736/
Summaries are generated and may contain mistakes; the official description above is the record.
