{"answers":{"affected":"4 open source packages ship an affected version, including thorsten/phpmyfaq and phpmyfaq/phpmyfaq.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56737 exists.","fix":"Upgrade thorsten/phpmyfaq to 4.1.6 or later.","what":"CVE-2026-56737 is a high-severity authentication bypass vulnerability in thorsten phpMyFAQ, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-56737 and fix it if it is affected.\n\nWhat it is: CVE-2026-56737 is a high-severity authentication bypass vulnerability in thorsten phpMyFAQ, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56737 exists.\n\nAffected packages and fixed versions:\n- thorsten/phpmyfaq (Packagist): affected from 3.2.0; fixed in 4.1.6\n- thorsten/phpmyfaq (Packagist): affected from 3.2.0; fixed in 4.1.6\n- phpmyfaq/phpmyfaq (Packagist): affected from 3.2.0; fixed in 4.1.6\n- phpmyfaq/phpmyfaq (Packagist): affected from 3.2.0; fixed in 4.1.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-56737/ (Markdown: https://insights.sbomify.com/CVE-2026-56737/index.md)","id":"CVE-2026-56737","markdown":"https://insights.sbomify.com/CVE-2026-56737/index.md","name":"CVE-2026-56737","record":{"aliases":["GHSA-8gpw-xvpf-hvx5"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"phpMyFAQ","requires_auth":"none","summary":"Unauthenticated attackers can bypass password authentication by submitting a valid TOTP code, leading to account takeover of any 2FA-enabled user.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"phpMyFAQ is an open source FAQ web application. Versions 3.2.0 through 4.1.5 contain an authentication bypass in its public two-factor authentication verification flow: an unauthenticated attacker can submit an account’s numeric user ID and a valid or brute-forced six-digit TOTP code without first authenticating with the account password, allowing takeover of any 2FA-enabled account, including administrator accounts. Version 4.1.6 is patched by binding TOTP verification to a session established after successful password authentication and limiting failed TOTP attempts. No official workaround is documented; affected installations should upgrade to 4.1.6 or later.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"phpMyFAQ's two-factor authentication login bypasses the password factor","id":"CVE-2026-56737","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":4,"n_references":4,"next":{"headline":"phpMyFAQ has SQL Injection in `StopWords::add()` — Unescaped Stop Word Insertion","id":"CVE-2026-56738"},"packages":[{"ecosystem":"Packagist","fixed":["4.1.6"],"introduced":["3.2.0"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":null,"source":"GHSA-8gpw-xvpf-hvx5"},{"ecosystem":"Packagist","fixed":["4.1.6"],"introduced":["3.2.0"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":"pkg:composer/phpmyfaq/phpmyfaq","source":"GHSA-8gpw-xvpf-hvx5"},{"ecosystem":"Packagist","fixed":["4.1.6"],"introduced":["3.2.0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":null,"source":"GHSA-8gpw-xvpf-hvx5"},{"ecosystem":"Packagist","fixed":["4.1.6"],"introduced":["3.2.0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":"pkg:composer/thorsten/phpmyfaq","source":"GHSA-8gpw-xvpf-hvx5"}],"prev":{"headline":"phpMyFAQ has Stored XSS in Admin FAQ Editor via HTML Entity Bypass in Frontend FAQ Submission","id":"CVE-2026-56736"},"products":["phpMyFAQ"],"published":"2026-09-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-29","vendors":["thorsten"]},"summary":"Unauthenticated attackers can bypass password authentication by submitting a valid TOTP code, leading to account takeover of any 2FA-enabled user.","url":"https://insights.sbomify.com/CVE-2026-56737/"}