# CVE-2026-56737: phpMyFAQ's two-factor authentication login bypasses the password factor

> Unauthenticated attackers can bypass password authentication by submitting a valid TOTP code, leading to account takeover of any 2FA-enabled user.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** GHSA-8gpw-xvpf-hvx5

## What is CVE-2026-56737?

CVE-2026-56737 is a high-severity authentication bypass vulnerability in thorsten phpMyFAQ, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

phpMyFAQ is an open source FAQ web application. Versions 3.2.0 through 4.1.5 contain an authentication bypass in its public two-factor authentication verification flow: an unauthenticated attacker can submit an account’s numeric user ID and a valid or brute-forced six-digit TOTP code without first authenticating with the account password, allowing takeover of any 2FA-enabled account, including administrator accounts. Version 4.1.6 is patched by binding TOTP verification to a session established after successful password authentication and limiting failed TOTP attempts. No official workaround is documented; affected installations should upgrade to 4.1.6 or later.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-56737?

4 open source packages ship an affected version, including thorsten/phpmyfaq and phpmyfaq/phpmyfaq.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thorsten/phpmyfaq` | Packagist | From 3.2.0 | 4.1.6 |
| `thorsten/phpmyfaq` | Packagist | From 3.2.0 | 4.1.6 |
| `phpmyfaq/phpmyfaq` | Packagist | From 3.2.0 | 4.1.6 |
| `phpmyfaq/phpmyfaq` | Packagist | From 3.2.0 | 4.1.6 |

## How do I fix CVE-2026-56737?

Upgrade thorsten/phpmyfaq to 4.1.6 or later.

## Is CVE-2026-56737 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56737 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56737 and fix it if it is affected.

What it is: CVE-2026-56737 is a high-severity authentication bypass vulnerability in thorsten phpMyFAQ, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56737 exists.

Affected packages and fixed versions:
- thorsten/phpmyfaq (Packagist): affected from 3.2.0; fixed in 4.1.6
- thorsten/phpmyfaq (Packagist): affected from 3.2.0; fixed in 4.1.6
- phpmyfaq/phpmyfaq (Packagist): affected from 3.2.0; fixed in 4.1.6
- phpmyfaq/phpmyfaq (Packagist): affected from 3.2.0; fixed in 4.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56737/ (Markdown: https://insights.sbomify.com/CVE-2026-56737/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56737
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56737
- OSV: https://osv.dev/vulnerability/CVE-2026-56737

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56737/
Summaries are generated and may contain mistakes; the official description above is the record.
