CVE-2026-56740 JLine: Unauthenticated Remote Memory Exhaustion via Unbounded Telnet NEW-ENVIRON Variables
Unauthenticated attackers can exhaust JVM memory via unbounded Telnet environment variables, causing denial of service in applications using JLine.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-56740?
CVE-2026-56740 is a high-severity denial of service vulnerability in jline3, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
JLine is a Java library for handling console input. Prior to 3.30.14, 4.0.16, and 4.2.1, the JLine3 Telnet server remote-telnet module does not limit the number of environment variables a client may inject via the Telnet NEW-ENVIRON option, and TelnetIO.readNEVariables() in TelnetIO.java:1127-1180 stores each variable pair in a HashMap held by ConnectionData, allowing an unauthenticated attacker to flood unique variable pairs before the terminating IAC SE byte and exhaust JVM heap memory with an OutOfMemoryError. This issue is fixed in versions 3.30.14, 4.0.16, and 4.2.1.
Weakness: CWE-400
Which versions are affected by CVE-2026-56740?
6 open source packages ship an affected version, including org.jline:jline-remote-telnet. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.jline:jline-remote-telnet Maven | All versions | 3.30.14 |
org.jline:jline-remote-telnet Maven | All versions | 3.30.14 |
org.jline:jline-remote-telnet Maven | From 4.0.0 | 4.0.16 |
org.jline:jline-remote-telnet Maven | From 4.0.0 | 4.0.16 |
org.jline:jline-remote-telnet Maven | From 4.1.0 | 4.2.1 |
org.jline:jline-remote-telnet Maven | From 4.1.0 | 4.2.1 |
Products include Jline Jline.
How do I fix CVE-2026-56740?
Upgrade org.jline:jline-remote-telnet to a fixed version for your release line: 3.30.14, 4.0.16 or 4.2.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-56740 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56740 exists.
Other vulnerabilities in jline3
Sources
Also known as AZL-92450, CLEANSTART-2026-HI15908, CLEANSTART-2026-JG25359, CLEANSTART-2026-RC30814, DEBIAN-CVE-2026-56740, ECHO-227b-e898-679d and 34 more.