# CVE-2026-56740: JLine: Unauthenticated Remote Memory Exhaustion via Unbounded Telnet NEW-ENVIRON Variables

> Unauthenticated attackers can exhaust JVM memory via unbounded Telnet environment variables, causing denial of service in applications using JLine.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2026
- **Updated:** 20 Jul 2026
- **Also known as:** AZL-92450, CLEANSTART-2026-HI15908, CLEANSTART-2026-JG25359, CLEANSTART-2026-RC30814, DEBIAN-CVE-2026-56740, ECHO-227b-e898-679d, GHSA-47qp-hqvx-6r3f, MINI-237r-mxq5-9xwv, MINI-2hc7-qx7m-66jc, MINI-4p7h-7cf4-jhc3, MINI-723q-cc27-p8hj, MINI-79h3-68fr-w9v3, MINI-7r4c-v965-36fp, MINI-8c35-v7x2-rcfq, MINI-969f-c6v5-h999, MINI-cp2j-28cc-wh55, MINI-f864-cj5c-v22r, MINI-f94x-5383-c856, MINI-fcgr-j9ww-5f2q, MINI-fppj-gfpp-6fw7, MINI-g2ww-vjcj-v8gp, MINI-gc97-qqp2-gjvw, MINI-gr4q-pxgc-mc3j, MINI-gv96-9jf2-fg7r, MINI-jhx3-85qr-2m5h, MINI-m83g-rhgr-h94h, MINI-mm6f-pq96-xwj9, MINI-p2c5-c9qf-m5q9, MINI-p3jh-6rjq-7xpc, MINI-p68w-8c79-7v46, MINI-pg6p-cw9x-3r3v, MINI-phf7-gg4f-fh36, MINI-rrg2-jfc8-33hx, MINI-rxv7-6hpf-cwvr, MINI-v7ph-435g-9478, MINI-vm5f-8rw2-r8g5, MINI-x3xg-93h9-chw6, ROOT-APP-MAVEN-CVE-2026-56740, ROOT-APP-MAVEN-GHSA-47qp-hqvx-6r3f, UBUNTU-CVE-2026-56740

## What is CVE-2026-56740?

CVE-2026-56740 is a high-severity denial of service vulnerability in jline3, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

JLine is a Java library for handling console input. Prior to 3.30.14, 4.0.16, and 4.2.1, the JLine3 Telnet server remote-telnet module does not limit the number of environment variables a client may inject via the Telnet NEW-ENVIRON option, and TelnetIO.readNEVariables() in TelnetIO.java:1127-1180 stores each variable pair in a HashMap held by ConnectionData, allowing an unauthenticated attacker to flood unique variable pairs before the terminating IAC SE byte and exhaust JVM heap memory with an OutOfMemoryError. This issue is fixed in versions 3.30.14, 4.0.16, and 4.2.1.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-56740?

6 open source packages ship an affected version, including org.jline:jline-remote-telnet. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jline:jline-remote-telnet` | Maven | All versions | 3.30.14 |
| `org.jline:jline-remote-telnet` | Maven | All versions | 3.30.14 |
| `org.jline:jline-remote-telnet` | Maven | From 4.0.0 | 4.0.16 |
| `org.jline:jline-remote-telnet` | Maven | From 4.0.0 | 4.0.16 |
| `org.jline:jline-remote-telnet` | Maven | From 4.1.0 | 4.2.1 |
| `org.jline:jline-remote-telnet` | Maven | From 4.1.0 | 4.2.1 |

Products: Jline Jline.

## How do I fix CVE-2026-56740?

Upgrade org.jline:jline-remote-telnet to a fixed version for your release line: 3.30.14, 4.0.16 or 4.2.1.

## Is CVE-2026-56740 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56740 exists.

## Other vulnerabilities in jline3

- [CVE-2026-56741](https://insights.sbomify.com/CVE-2026-56741/): JLine: Unauthenticated Remote DoS via Unbounded Telnet NAWS Terminal Geometry (high 7.5)
- [CVE-2023-50572](https://insights.sbomify.com/CVE-2023-50572/): JLine vulnerable to out of memory error (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56740 and fix it if it is affected.

What it is: CVE-2026-56740 is a high-severity denial of service vulnerability in jline3, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56740 exists.

Affected packages and fixed versions:
- org.jline:jline-remote-telnet (Maven): affected all versions; fixed in 3.30.14
- org.jline:jline-remote-telnet (Maven): affected all versions; fixed in 3.30.14
- org.jline:jline-remote-telnet (Maven): affected from 4.0.0; fixed in 4.0.16
- org.jline:jline-remote-telnet (Maven): affected from 4.0.0; fixed in 4.0.16
- org.jline:jline-remote-telnet (Maven): affected from 4.1.0; fixed in 4.2.1
- org.jline:jline-remote-telnet (Maven): affected from 4.1.0; fixed in 4.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56740/ (Markdown: https://insights.sbomify.com/CVE-2026-56740/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56740
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56740
- OSV: https://osv.dev/vulnerability/CVE-2026-56740

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56740/
Summaries are generated and may contain mistakes; the official description above is the record.
