# CVE-2026-56743: Cilium may unexpectedly allow ingress traffic from the local namespace when a Kubernetes NetworkPolicy is configured with an ipBlock match

> Cilium incorrectly allows ingress traffic from the local namespace when using specific NetworkPolicy ipBlock rules with a custom clusterName, bypassing intended network isolation.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2026
- **Updated:** 16 Jul 2026
- **Also known as:** BIT-cilium-2026-56743, BIT-cilium-operator-2026-56743, BIT-hubble-relay-2026-56743, GHSA-fm8w-2m5w-9j7r, GO-2026-6367, MINI-2p8v-pvgj-wc6f, MINI-2wvm-mx9p-q968, MINI-5244-f9pc-8mhq, MINI-5mvp-r3h9-5484, MINI-f6c8-2xwg-jw76, MINI-g69v-v3vg-rcjx, MINI-gc2v-4h6j-9qhv, MINI-hh43-hm9q-mffq, MINI-hmx6-wgff-3jx8, MINI-mr5r-cxwf-4gj8, MINI-v895-4c23-c359, MINI-vcpw-hrrm-9j4c, MINI-vp4f-vc39-hqwm, MINI-vpmg-98q4-hpfj, MINI-vqh8-j2jc-wx87, MINI-xj9f-q2p4-55g5

## What is CVE-2026-56743?

CVE-2026-56743 is a medium-severity missing authorization vulnerability in cilium, published on 15 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Cilium is a networking, observability, and security solution. From 1.19.0 to 1.19.4, standard Kubernetes NetworkPolicy specifications using CIDR-based ipBlock rules without pod or namespace selectors erroneously generate a wildcard namespace allow rule when Cilium is configured with a custom clusterName rather than the default any value. The parser incorrectly instantiates a pod selector on selectorless peer definitions, allowing traffic from other workloads in the same namespace as the subject of the policy. This issue is fixed in version 1.19.5.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-56743?

6 open source packages ship an affected version, including github.com/cilium/cilium, cilium and cilium-operator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cilium/cilium` | Go | From 1.19.0 | 1.19.5 |
| `github.com/cilium/cilium` | Go | From 1.19.0 | 1.19.5 |
| `github.com/cilium/cilium` | Go | From 1.19.0 | 1.19.5 |
| `cilium` | Bitnami | From 1.19.0 | 1.19.5 |
| `cilium-operator` | Bitnami | From 1.19.0 | 1.19.5 |
| `hubble-relay` | Bitnami | From 1.19.0 | 1.19.5 |

Products: Cilium Cilium.

## How do I fix CVE-2026-56743?

Upgrade github.com/cilium/cilium to 1.19.5 or later.

## Is CVE-2026-56743 being exploited?

There is no known exploitation of CVE-2026-56743 in the wild and no public exploit code.

## Other vulnerabilities in cilium

- [CVE-2026-49445](https://insights.sbomify.com/CVE-2026-49445/): Cilium: Sensitive information disclosure and cluster disruption via local Envoy admin socket access (critical 9.2)
- [CVE-2022-29178](https://insights.sbomify.com/CVE-2022-29178/): Incorrect Default Permissions in Cilium (high 8.8)
- [CVE-2024-28860](https://insights.sbomify.com/CVE-2024-28860/): Insecure IPsec transport encryption in Cilium (high 8.0)
- [CVE-2026-41520](https://insights.sbomify.com/CVE-2026-41520/): Cillium exposes sensitive information included in the cilium-bugtool debug archive (high 7.9)
- [CVE-2024-37307](https://insights.sbomify.com/CVE-2024-37307/): Cilium leaks sensitive information in cilium-bugtool (high 7.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56743 and fix it if it is affected.

What it is: CVE-2026-56743 is a medium-severity missing authorization vulnerability in cilium, published on 15 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-56743 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cilium/cilium (Go): affected from 1.19.0; fixed in 1.19.5
- github.com/cilium/cilium (Go): affected from 1.19.0; fixed in 1.19.5
- github.com/cilium/cilium (Go): affected from 1.19.0; fixed in 1.19.5
- cilium (Bitnami): affected from 1.19.0; fixed in 1.19.5
- cilium-operator (Bitnami): affected from 1.19.0; fixed in 1.19.5
- hubble-relay (Bitnami): affected from 1.19.0; fixed in 1.19.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56743/ (Markdown: https://insights.sbomify.com/CVE-2026-56743/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56743
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56743
- OSV: https://osv.dev/vulnerability/CVE-2026-56743

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56743/
Summaries are generated and may contain mistakes; the official description above is the record.
