# CVE-2026-56744: `@bsv/wallet-toolbox` / `-client` / `-mobile` don't verify storage-supplied recipient output scripts against caller-requested outputs in createAction

> A malicious storage provider can redirect cryptocurrency payments by injecting unauthorized transaction outputs that bypass client-side verification in BSV wallet libraries.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** GHSA-36f9-7rg5-cpf8

## What is CVE-2026-56744?

CVE-2026-56744 is a high-severity vulnerability in bsv-blockchain @bsv/wallet-toolbox, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

`@bsv/wallet-toolbox` provides BRC-100 wallet signing and storage components, while `@bsv/wallet-toolbox-client` and `@bsv/wallet-toolbox-mobile` provide client-focused distributions for standard and mobile applications using wallet storage services. A vulnerability in these packages causes transactions created through a remote `StorageClient` to trust output locking scripts returned by the storage provider without verifying that they match the outputs requested by the caller. A malicious or compromised storage provider can substitute a recipient script or inject an additional output, causing the wallet to sign and broadcast a transaction that redirects funds while the application and user interface continue to display the intended recipient. Source and npm publication history indicate that stable versions `@bsv/wallet-toolbox` and `@bsv/wallet-toolbox-client` from 1.1.47 through 2.3.3, and `@bsv/wallet-toolbox-mobile` from its initial 1.3.21 release through 2.3.3, are affected. All three packages are patched in version 2.4.0. Applications unable to upgrade should avoid remote `StorageClient` providers, use local storage, or independently verify every transaction output’s locking script and value against the original request before signing

Weakness: CWE-1288 (Improper Validation of Consistency within Input)

## Which versions are affected by CVE-2026-56744?

6 open source packages ship an affected version, including @bsv/wallet-toolbox, @bsv/wallet-toolbox-client and @bsv/wallet-toolbox-mobile.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@bsv/wallet-toolbox` | npm | From 1.1.47 | 2.4.0 |
| `@bsv/wallet-toolbox` | npm | From 1.1.47 | 2.4.0 |
| `@bsv/wallet-toolbox-client` | npm | From 1.1.47 | 2.4.0 |
| `@bsv/wallet-toolbox-client` | npm | From 1.1.47 | 2.4.0 |
| `@bsv/wallet-toolbox-mobile` | npm | From 1.3.21 | 2.4.0 |
| `@bsv/wallet-toolbox-mobile` | npm | From 1.3.21 | 2.4.0 |

## How do I fix CVE-2026-56744?

Upgrade @bsv/wallet-toolbox to 2.4.0 or later.

## Is CVE-2026-56744 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56744 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56744 and fix it if it is affected.

What it is: CVE-2026-56744 is a high-severity vulnerability in bsv-blockchain @bsv/wallet-toolbox, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56744 exists.

Affected packages and fixed versions:
- @bsv/wallet-toolbox (npm): affected from 1.1.47; fixed in 2.4.0
- @bsv/wallet-toolbox (npm): affected from 1.1.47; fixed in 2.4.0
- @bsv/wallet-toolbox-client (npm): affected from 1.1.47; fixed in 2.4.0
- @bsv/wallet-toolbox-client (npm): affected from 1.1.47; fixed in 2.4.0
- @bsv/wallet-toolbox-mobile (npm): affected from 1.3.21; fixed in 2.4.0
- @bsv/wallet-toolbox-mobile (npm): affected from 1.3.21; fixed in 2.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56744/ (Markdown: https://insights.sbomify.com/CVE-2026-56744/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56744
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56744
- OSV: https://osv.dev/vulnerability/CVE-2026-56744

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56744/
Summaries are generated and may contain mistakes; the official description above is the record.
