# CVE-2026-56745: Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion

> A remote attacker can cause native memory exhaustion and denial of service by triggering a ByteBuf reference leak in the Netty SPDY decoder.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jul 2026
- **Updated:** 22 Jul 2026
- **Also known as:** CLEANSTART-2026-EG79698, CLEANSTART-2026-KG33218, CLEANSTART-2026-KM44899, CLEANSTART-2026-PM11984, CLEANSTART-2026-XB82497, DEBIAN-CVE-2026-56745, ECHO-440e-bb87-aa81, GHSA-jppx-w49h-x2qq, MINI-245g-vvcv-c924, MINI-2737-cw4c-hvpq, MINI-2cv7-7mr4-whjq, MINI-2f4v-jj4h-883f, MINI-2gq9-c9qj-x8jw, MINI-2h4w-q89c-rx66, MINI-2r5m-hfch-r5vv, MINI-2wxx-894f-jvfr, MINI-3qq9-23jp-95h3, MINI-478m-r577-hr5c, MINI-4whp-7v8x-wrw6, MINI-4x84-3c8w-x6r7, MINI-597r-xj2h-v8m8, MINI-5cx7-gg65-559h, MINI-5hcg-wfpf-pwh2, MINI-5jhq-4wr3-gp32, MINI-6435-6q83-h484, MINI-67hc-8rgx-g8wx, MINI-69gp-c75h-w3j6, MINI-6f3h-j32w-j7wr, MINI-6g64-gq9w-8rcv, MINI-6jw5-76qp-qm56, MINI-6pxf-6cq6-hvgj, MINI-6wjp-9j2r-x68g, MINI-76xf-rp8x-qfc6, MINI-783x-j4gx-qwr7, MINI-79hm-hwqm-g58j, MINI-7cv7-fv3w-m968, MINI-7mq7-c29c-wqw4, MINI-7p65-pqm3-gq3r, MINI-8364-xx59-49c4, MINI-8753-qgvw-f678, MINI-8946-2pxp-4753, MINI-89v4-gj6v-pgx2, MINI-8cw3-w9pq-xxg3, MINI-8mf6-f4h9-927g, MINI-8q8p-2gq3-jrh7, MINI-944v-ww8v-mr65, MINI-95qx-q37m-qm2r, MINI-9848-xrhq-282p, MINI-9f4j-j43m-7575, MINI-9fvr-m7h8-fv53, MINI-9jgr-3fqv-vmqw, MINI-9jhr-chwj-m6vm, MINI-9p9r-443j-7jp3, MINI-9r8h-jw9f-88v3, MINI-9r95-2j75-59pc, MINI-c355-48q9-4g9m, MINI-c97g-62rg-3wgg, MINI-c9qm-jq8g-5v6j, MINI-ch66-m54h-wgq3, MINI-cr86-2j55-qmx9, MINI-f4m2-mp2p-c73v, MINI-f5vq-p9r6-8f54, MINI-fcgx-2rcr-p3x5, MINI-fcw4-mh7m-hpqq, MINI-frq8-jpqw-wmhh, MINI-g3mq-v588-8v3j, MINI-g8cm-5r2f-672m, MINI-g9cw-frr8-mffr, MINI-gh3x-qhm6-frwc, MINI-gvgw-4p3c-mh9v, MINI-gx48-r38x-7cv2, MINI-h54m-9m4g-9438, MINI-h83m-5356-6jfp, MINI-h9xf-m6wv-jr5j, MINI-hch6-8xf3-jrjf, MINI-hjmx-4v7c-qhh3, MINI-hwmr-jc22-3833, MINI-hxfw-w52x-92q5, MINI-j4g9-522g-xw58, MINI-j7xw-p6h8-j966, MINI-jf28-wf8g-7473, MINI-jvgv-2g4p-2h65, MINI-m4g9-426m-3c92, MINI-m5wc-hxx4-mrwx, MINI-mm73-58w6-8h2h, MINI-mr98-5pv4-9672, MINI-mxxg-vvhx-vhf5, MINI-p2j6-pm2c-6r47, MINI-p3wp-63cw-9cw2, MINI-p4vx-gvwx-2grh, MINI-p663-qgcx-32gv, MINI-p9fx-596f-7c8v, MINI-pf7g-36gv-3f25, MINI-pm3f-7q59-mhf6, MINI-ppwc-r463-2h8j, MINI-pv7p-452v-844x, MINI-q669-947h-rrjf, MINI-q9m4-gv6g-h392, MINI-qwfv-vv6f-qvgr, MINI-qwqf-c2rp-pqq9, MINI-r65f-3367-rvfx, MINI-r8rr-4mcq-3495, MINI-v57h-x453-x37p, MINI-v62w-wv9f-6m25, MINI-v662-f5x6-j5pr, MINI-vcqh-5fcx-h839, MINI-w46c-6rww-6hrh, MINI-w6xv-h9m5-f2qx, MINI-w8hj-x3cj-xwc9, MINI-wf6h-grw7-rmrj, MINI-wq3r-4q2p-qg67, MINI-wxpc-f73q-f5mv, MINI-x59r-63mh-m5gf, ROOT-APP-MAVEN-CVE-2026-56745, UBUNTU-CVE-2026-56745

## What is CVE-2026-56745?

CVE-2026-56745 is a high-severity denial of service vulnerability in Netty Netty, published on 21 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Netty is a network application framework for development of protocol servers and clients. In versions 4.2.0.Final through 4.2.15.Final and 4.1.0.Final through 4.1.135.Final, the `SpdyHttpDecoder` handler in Netty's SPDY-to-HTTP codec allocates a pooled `ByteBuf` when processing a client-initiated `SYN_STREAM` frame with `FLAG_FIN=0` and stores the partially constructed `FullHttpRequest` in `messageMap`; when the remote peer sends `RST_STREAM` for that stream or the accumulated content exceeds `maxContentLength`, the decoder removes the entry but does not release the pooled `ByteBuf`, causing native memory exhaustion. This issue is fixed in versions 4.1.136.Final and 4.2.16.Final.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-56745?

4 open source packages ship an affected version, including io.netty:netty-codec-http. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty-codec-http` | Maven | From 4.1.0.Final | 4.1.136.Final |
| `io.netty:netty-codec-http` | Maven | From 4.1.0.Final | 4.1.136.Final |
| `io.netty:netty-codec-http` | Maven | From 4.2.0.Final | 4.2.16.Final |
| `io.netty:netty-codec-http` | Maven | From 4.2.0.Final | 4.2.16.Final |

Products: Netty Netty.

## How do I fix CVE-2026-56745?

Upgrade io.netty:netty-codec-http to a fixed version for your release line: 4.1.136.Final or 4.2.16.Final.

## Is CVE-2026-56745 being exploited?

There is no known exploitation of CVE-2026-56745 in the wild and no public exploit code.

## Other vulnerabilities in Netty Netty

- [CVE-2026-75595](https://insights.sbomify.com/CVE-2026-75595/): Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext (critical 9.1)
- [CVE-2026-75596](https://insights.sbomify.com/CVE-2026-75596/): Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing (high 8.7)
- [CVE-2026-59901](https://insights.sbomify.com/CVE-2026-59901/): Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang (high 8.7)
- [CVE-2026-55851](https://insights.sbomify.com/CVE-2026-55851/): Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion (high 8.7)
- [CVE-2026-45674](https://insights.sbomify.com/CVE-2026-45674/): Netty Vulnerable to DNS Cache Poisoning via Missing Bailiwick Checks in CNAME Records (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56745 and fix it if it is affected.

What it is: CVE-2026-56745 is a high-severity denial of service vulnerability in Netty Netty, published on 21 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-56745 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.netty:netty-codec-http (Maven): affected from 4.1.0.Final; fixed in 4.1.136.Final
- io.netty:netty-codec-http (Maven): affected from 4.1.0.Final; fixed in 4.1.136.Final
- io.netty:netty-codec-http (Maven): affected from 4.2.0.Final; fixed in 4.2.16.Final
- io.netty:netty-codec-http (Maven): affected from 4.2.0.Final; fixed in 4.2.16.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56745/ (Markdown: https://insights.sbomify.com/CVE-2026-56745/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56745
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56745
- OSV: https://osv.dev/vulnerability/CVE-2026-56745

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56745/
Summaries are generated and may contain mistakes; the official description above is the record.
