# CVE-2026-56764: Hono - Timing Attack in basicAuth and bearerAuth Middleware

> Attackers can infer valid credentials via timing attacks in Hono's basicAuth and bearerAuth middlewares due to non-constant-time string comparisons.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-98q5-3v5r-qvfh, GHSA-gq3j-xvxp-8hrf, MINI-8jw2-hw2p-75jv, MINI-cr23-mgwf-wr67, MINI-xq72-r823-549r

## What is CVE-2026-56764?

CVE-2026-56764 is a medium-severity vulnerability in Hono, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Hono before 4.11.10 contains a timing attack vulnerability in the basicAuth and bearerAuth middlewares due to non-constant-time string comparison in the timingSafeEqual function. Attackers can exploit early termination of string equality checks to infer valid credentials through precise timing measurements.

Weakness: CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2026-56764?

2 open source packages ship an affected version, including hono.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hono` | npm | All versions | 4.11.10 |
| `hono` | npm | All versions | 4.11.10 |

## How do I fix CVE-2026-56764?

Upgrade hono to 4.11.10 or later.

## Is CVE-2026-56764 being exploited?

There is no known exploitation of CVE-2026-56764 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56764 and fix it if it is affected.

What it is: CVE-2026-56764 is a medium-severity vulnerability in Hono, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-56764 in the wild and no public exploit code.

Affected packages and fixed versions:
- hono (npm): affected all versions; fixed in 4.11.10
- hono (npm): affected all versions; fixed in 4.11.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56764/ (Markdown: https://insights.sbomify.com/CVE-2026-56764/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56764
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56764
- OSV: https://osv.dev/vulnerability/CVE-2026-56764

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56764/
Summaries are generated and may contain mistakes; the official description above is the record.
