CVE-2026-56775 n8n - Incorrect OAuth Scope Validation in Evaluation Test Runs Endpoints
Authenticated viewers can modify evaluation test runs due to incorrect OAuth scope validation in n8n's Advanced Permissions mode.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-56775?
CVE-2026-56775 is a medium-severity missing authorization vulnerability in N8n N8n, published on 8 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n before 1.123.55, 2.25.7, and 2.26.2 contains an authorization vulnerability in three mutating evaluation test-run endpoints that authorize state-changing actions using the workflow:read scope instead of the action-appropriate workflow:execute scope. On instances using Advanced Permissions (Enterprise/Cloud) with projects and viewer roles, an authenticated user with the project:viewer role can start new evaluation test runs, cancel in-flight runs, and delete run records for workflows they only have read access to.
Weakness: CWE-863
Which versions are affected by CVE-2026-56775?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.55 |
n8n npm | All versions | 1.123.55 |
n8n npm | From 2.0.0-rc.0 | 2.25.7 |
n8n npm | From 2.0.0-rc.0 | 2.25.7 |
n8n npm | From 2.26.0 | 2.26.2 |
n8n npm | From 2.26.0 | 2.26.2 |
Products include N8n N8n.
How do I fix CVE-2026-56775?
Upgrade n8n to a fixed version for your release line: 1.123.55, 2.25.7 or 2.26.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-56775 being exploited?
There is no known exploitation of CVE-2026-56775 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-664h-gpgq-h6xx, GHSA-w79j-mf7m-gfpm, MINI-34g9-w959-gp3h, MINI-76gc-996m-92rr, ROOT-APP-NPM-GHSA-664h-gpgq-h6xx.