# CVE-2026-56775: n8n - Incorrect OAuth Scope Validation in Evaluation Test Runs Endpoints

> Authenticated viewers can modify evaluation test runs due to incorrect OAuth scope validation in n8n's Advanced Permissions mode.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-664h-gpgq-h6xx, GHSA-w79j-mf7m-gfpm, MINI-34g9-w959-gp3h, MINI-76gc-996m-92rr, ROOT-APP-NPM-GHSA-664h-gpgq-h6xx

## What is CVE-2026-56775?

CVE-2026-56775 is a medium-severity missing authorization vulnerability in N8n N8n, published on 8 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

n8n before 1.123.55, 2.25.7, and 2.26.2 contains an authorization vulnerability in three mutating evaluation test-run endpoints that authorize state-changing actions using the workflow:read scope instead of the action-appropriate workflow:execute scope. On instances using Advanced Permissions (Enterprise/Cloud) with projects and viewer roles, an authenticated user with the project:viewer role can start new evaluation test runs, cancel in-flight runs, and delete run records for workflows they only have read access to.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-56775?

6 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | All versions | 1.123.55 |
| `n8n` | npm | All versions | 1.123.55 |
| `n8n` | npm | From 2.0.0-rc.0 | 2.25.7 |
| `n8n` | npm | From 2.0.0-rc.0 | 2.25.7 |
| `n8n` | npm | From 2.26.0 | 2.26.2 |
| `n8n` | npm | From 2.26.0 | 2.26.2 |

Products: N8n N8n.

## How do I fix CVE-2026-56775?

Upgrade n8n to a fixed version for your release line: 1.123.55, 2.25.7 or 2.26.2.

## Is CVE-2026-56775 being exploited?

There is no known exploitation of CVE-2026-56775 in the wild and no public exploit code.

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56775 and fix it if it is affected.

What it is: CVE-2026-56775 is a medium-severity missing authorization vulnerability in N8n N8n, published on 8 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-56775 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected all versions; fixed in 1.123.55
- n8n (npm): affected all versions; fixed in 1.123.55
- n8n (npm): affected from 2.0.0-rc.0; fixed in 2.25.7
- n8n (npm): affected from 2.0.0-rc.0; fixed in 2.25.7
- n8n (npm): affected from 2.26.0; fixed in 2.26.2
- n8n (npm): affected from 2.26.0; fixed in 2.26.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56775/ (Markdown: https://insights.sbomify.com/CVE-2026-56775/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56775
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56775
- OSV: https://osv.dev/vulnerability/CVE-2026-56775

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56775/
Summaries are generated and may contain mistakes; the official description above is the record.
