CVE-2026-56776 n8n - Incorrect OAuth Scope Validation in Workflow Test Run Endpoint
Authenticated users with read-only workflow access can execute workflows due to incorrect OAuth scope validation, causing unintended side effects.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-56776?
CVE-2026-56776 is a medium-severity missing authorization vulnerability in N8n N8n, published on 8 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n before 1.123.55, 2.25.7, and 2.26.2 contains an authorization bypass in the POST /workflows/{workflowId}/test-runs/new endpoint, which authorizes access using the workflow:read scope instead of workflow:execute. An authenticated user with read-only access to a workflow can trigger a real evaluation test run, causing the workflow to execute via the internal workflow runner and resulting in unintended outbound API calls, data mutations, or other side effects in connected downstream systems. The issue primarily affects instances using the Evaluations feature where RBAC project roles grant workflow:read without workflow:execute.
Weakness: CWE-863
Which versions are affected by CVE-2026-56776?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.55 |
n8n npm | All versions | 1.123.55 |
n8n npm | From 2.0.0-rc.0 | 2.25.7 |
n8n npm | From 2.0.0-rc.0 | 2.25.7 |
n8n npm | From 2.26.0 | 2.26.2 |
n8n npm | From 2.26.0 | 2.26.2 |
Products include N8n N8n.
How do I fix CVE-2026-56776?
Upgrade n8n to a fixed version for your release line: 1.123.55, 2.25.7 or 2.26.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-56776 being exploited?
There is no known exploitation of CVE-2026-56776 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-hv7x-3x78-gx53, GHSA-xhqv-vmw5-79pm, MINI-5v6w-j23r-jj7p, MINI-w862-9vwh-xppv, ROOT-APP-NPM-GHSA-hv7x-3x78-gx53.