# CVE-2026-56777: n8n - AST Validator Bypass in Python Code Node

> Authenticated users can bypass AST validation in n8n's Python Code node to access task executor namespaces and potentially disclose environment variables.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jun 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-jwm3-qcfw-c5pp, GHSA-x2rh-rhm8-cv8v, MINI-542r-f3j8-vxp6, MINI-6mgr-v25c-g9mm, ROOT-APP-NPM-GHSA-jwm3-qcfw-c5pp

## What is CVE-2026-56777?

CVE-2026-56777 is a medium-severity vulnerability in N8n N8n, published on 30 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

n8n before 2.25.7 and 2.26.x before 2.26.2 contains an abstract syntax tree (AST) security validator bypass in the Python Code node. An authenticated user with permission to create or modify workflows containing a Python Code node can bypass the validator and access the task executor module namespace. The issue only affects self-hosted instances where the Python Task Runner is enabled; where N8N_BLOCK_RUNNER_ENV_ACCESS is configured to allow it, this can disclose environment variables accessible to the task runner process.

Weakness: CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2026-56777?

4 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | All versions | 2.25.7 |
| `n8n` | npm | All versions | 2.25.7 |
| `n8n` | npm | From 2.26.0 | 2.26.2 |
| `n8n` | npm | From 2.26.0 | 2.26.2 |

Products: N8n N8n.

## How do I fix CVE-2026-56777?

Upgrade n8n to a fixed version for your release line: 2.25.7 or 2.26.2.

## Is CVE-2026-56777 being exploited?

There is no known exploitation of CVE-2026-56777 in the wild and no public exploit code.

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56777 and fix it if it is affected.

What it is: CVE-2026-56777 is a medium-severity vulnerability in N8n N8n, published on 30 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-56777 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected all versions; fixed in 2.25.7
- n8n (npm): affected all versions; fixed in 2.25.7
- n8n (npm): affected from 2.26.0; fixed in 2.26.2
- n8n (npm): affected from 2.26.0; fixed in 2.26.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56777/ (Markdown: https://insights.sbomify.com/CVE-2026-56777/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56777
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56777
- OSV: https://osv.dev/vulnerability/CVE-2026-56777

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56777/
Summaries are generated and may contain mistakes; the official description above is the record.
