CVE-2026-56778 n8n - Authorization Bypass in Public API Execution Retry Endpoint
An authenticated user with read-only access can retry workflow executions via the Public API, bypassing execute permissions and potentially running unauthorized code.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-56778?
CVE-2026-56778 is a medium-severity missing authorization vulnerability in N8n N8n, published on 8 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n before 2.25.7 and 2.26.x before 2.26.2 contains an authorization bypass in the Public API execution retry endpoint, which authorizes access using the workflow:read scope instead of workflow:execute. An authenticated user with read-only access to a shared workflow can use the Public API to retry executions of that workflow, bypassing the intended permission boundary between read and execute access. This affects instances where workflows are shared with other users or across projects.
Weakness: CWE-863
Which versions are affected by CVE-2026-56778?
4 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 2.25.7 |
n8n npm | All versions | 2.25.7 |
n8n npm | From 2.26.0 | 2.26.2 |
n8n npm | From 2.26.0 | 2.26.2 |
Products include N8n N8n.
How do I fix CVE-2026-56778?
Upgrade n8n to a fixed version for your release line: 2.25.7 or 2.26.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-56778 being exploited?
There is no known exploitation of CVE-2026-56778 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-g7vr-5v44-rqf5, GHSA-h3jj-5f3v-3685, MINI-433c-qphp-wpc6, MINI-cx35-f8vq-mv45, ROOT-APP-NPM-GHSA-h3jj-5f3v-3685.