CVE-2026-56813 Cookie attribute injection in Plug.Conn.Cookies.encode/2
Attackers can inject cookie attributes to bypass security flags or hijack sessions in Elixir applications using the Plug library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-56813?
CVE-2026-56813 is a low-severity vulnerability in elixir-plug plug, published on 10 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Improper Neutralization of Parameter/Argument Delimiters vulnerability in elixir-plug plug allows an attacker to inject or override HTTP cookie attributes.
The Plug.Conn.Cookies.encode/2 function in lib/plug/conn/cookies.ex builds the Set-Cookie response header by interpolating the cookie value and its path, domain, same_site, and extra attributes directly into the header without neutralizing the ; delimiter that separates cookie attributes.
An application that places attacker-controlled data into a cookie value or attribute (for example via Plug.Conn.put_resp_cookie/4 when reflecting a username or preference) lets an attacker inject a ; to append or override cookie attributes (such as Domain and Path scope, or dropping the Secure and HttpOnly flags), enabling cookie tossing and session fixation. Carriage return, line feed, and null bytes are rejected by Plug.Conn header validation, so HTTP response splitting is not possible, but attribute injection through ; is not prevented.
This issue affects plug: from 0.1.0 before 1.16.6, from 1.17.0 before 1.17.4, from 1.18.0 before 1.18.5, from 1.19.1 before 1.19.5, and from 1.20.0 before 1.20.3.
Weakness: CWE-141
Which versions are affected by CVE-2026-56813?
1 open source package ship an affected version, including plug.
| Package | Affected | Fixed in |
|---|---|---|
plug Hex | From 0.1.0 | 1.16.6, 1.17.4, 1.18.5, 1.19.5, 1.20.3 |
How do I fix CVE-2026-56813?
Upgrade plug to a fixed version for your release line: 1.16.6, 1.17.4, 1.18.5 or 1.19.5.
Is CVE-2026-56813 being exploited?
There is no known exploitation of CVE-2026-56813 in the wild and no public exploit code.
Sources
Also known as EEF-CVE-2026-56813, GHSA-wpmj-jh88-rpgm.