{"answers":{"affected":"1 open source package ship an affected version, including plug.","exploited":"There is no known exploitation of CVE-2026-56813 in the wild and no public exploit code.","fix":"Upgrade plug to a fixed version for your release line: 1.16.6, 1.17.4, 1.18.5 or 1.19.5.","what":"CVE-2026-56813 is a low-severity vulnerability in elixir-plug plug, published on 10 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-56813 and fix it if it is affected.\n\nWhat it is: CVE-2026-56813 is a low-severity vulnerability in elixir-plug plug, published on 10 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-56813 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- plug (Hex): affected from 0.1.0; fixed in 1.16.6, 1.17.4, 1.18.5, 1.19.5, 1.20.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-56813/ (Markdown: https://insights.sbomify.com/CVE-2026-56813/index.md)","id":"CVE-2026-56813","markdown":"https://insights.sbomify.com/CVE-2026-56813/index.md","name":"CVE-2026-56813","record":{"aliases":["EEF-CVE-2026-56813","GHSA-wpmj-jh88-rpgm"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","account_takeover"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Elixir Plug library","requires_auth":"none","summary":"Attackers can inject cookie attributes to bypass security flags or hijack sessions in Elixir applications using the Plug library.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"EEF","cpe":[],"cvss":{"score":2.1,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-141","name":"Improper Neutralization of Parameter/Argument Delimiters"}],"description":"Improper Neutralization of Parameter/Argument Delimiters vulnerability in elixir-plug plug allows an attacker to inject or override HTTP cookie attributes.\n\nThe Plug.Conn.Cookies.encode/2 function in lib/plug/conn/cookies.ex builds the Set-Cookie response header by interpolating the cookie value and its path, domain, same_site, and extra attributes directly into the header without neutralizing the ; delimiter that separates cookie attributes.\n\nAn application that places attacker-controlled data into a cookie value or attribute (for example via Plug.Conn.put_resp_cookie/4 when reflecting a username or preference) lets an attacker inject a ; to append or override cookie attributes (such as Domain and Path scope, or dropping the Secure and HttpOnly flags), enabling cookie tossing and session fixation. Carriage return, line feed, and null bytes are rejected by Plug.Conn header validation, so HTTP response splitting is not possible, but attribute injection through ; is not prevented.\n\nThis issue affects plug: from 0.1.0 before 1.16.6, from 1.17.0 before 1.17.4, from 1.18.0 before 1.18.5, from 1.19.1 before 1.19.5, and from 1.20.0 before 1.20.3.","ecosystems":["Hex"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cookie attribute injection in Plug.Conn.Cookies.encode/2","id":"CVE-2026-56813","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Hex","product":null,"products":[],"type":"other","year":"2026"},"n_packages":1,"n_references":9,"next":{"headline":"Denial of service in plug","id":"CVE-2026-56814"},"packages":[{"ecosystem":"Hex","fixed":["1.16.6","1.17.4","1.18.5","1.19.5","1.20.3"],"introduced":["0.1.0","1.17.0","1.18.0","1.19.1","1.20.0"],"last_affected":[],"package":"plug","purl":"pkg:hex/plug","source":"EEF-CVE-2026-56813"}],"prev":{"headline":"Phoenix: Presence keys colliding with `Object.prototype` members break existence checks","id":"CVE-2026-56812"},"products":["plug"],"published":"2026-07-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Erlang Ecosystem Foundation","prefix":"EEF"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-24","vendors":["elixir-plug"]},"summary":"Attackers can inject cookie attributes to bypass security flags or hijack sessions in Elixir applications using the Plug library.","url":"https://insights.sbomify.com/CVE-2026-56813/"}