CVE-2026-56814 Denial of service in plug
An unauthenticated attacker can cause denial of service by sending multipart requests with many empty file parts, exhausting disk inodes and memory.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-56814?
CVE-2026-56814 is a medium-severity denial of service vulnerability in elixir-plug plug, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Plug.Parsers.MULTIPART, the multipart request-body parser used to handle file uploads and multipart forms, does not enforce its :length budget against all consumed resources, allowing an unauthenticated remote attacker to cause denial of service. The parser charges the :length limit only for part body bytes; part header bytes are never counted, and a part with an empty body costs zero.
Because every part whose Content-Disposition carries a non-empty filename creates a fresh temporary file (via Plug.Upload) and retains a Plug.Upload struct for the duration of the request, an attacker can send a single request composed of many empty-body file parts. Such a request stays well under the configured :length limit (8,000,000 bytes by default) while creating one temporary file per part, leading to inode and disk exhaustion and unbounded memory growth. Any application using Plug.Parsers with the :multipart parser is affected, and no authentication is required, only reachability of a multipart endpoint over HTTP.
This vulnerability is associated with program files lib/plug/parsers/multipart.ex and program routines Plug.Parsers.MULTIPART.parse_multipart/2, Plug.Parsers.MULTIPART.parse_multipart_headers/5, Plug.Parsers.MULTIPART.parse_multipart_body/4, and Plug.Parsers.MULTIPART.parse_multipart_file/4.
This issue affects plug: from 1.4.0-rc.0 before 1.16.6, from 1.17.0 before 1.17.4, from 1.18.0 before 1.18.5, from 1.19.1 before 1.19.5, and from 1.20.0 before 1.20.3.
Weakness: CWE-770
Which versions are affected by CVE-2026-56814?
1 open source package ship an affected version, including plug.
| Package | Affected | Fixed in |
|---|---|---|
plug Hex | From 1.4.0-rc.0 | 1.16.6, 1.17.4, 1.18.5, 1.19.5, 1.20.3 |
How do I fix CVE-2026-56814?
Upgrade plug to a fixed version for your release line: 1.16.6, 1.17.4, 1.18.5 or 1.19.5.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-56814 being exploited?
There is no known exploitation of CVE-2026-56814 in the wild and no public exploit code.
Sources
Also known as EEF-CVE-2026-56814, GHSA-95qv-c9g9-rm63.