{"answers":{"affected":"1 open source package ship an affected version, including plug.","exploited":"There is no known exploitation of CVE-2026-56814 in the wild and no public exploit code.","fix":"Upgrade plug to a fixed version for your release line: 1.16.6, 1.17.4, 1.18.5 or 1.19.5.","what":"CVE-2026-56814 is a medium-severity denial of service vulnerability in elixir-plug plug, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-56814 and fix it if it is affected.\n\nWhat it is: CVE-2026-56814 is a medium-severity denial of service vulnerability in elixir-plug plug, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-56814 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- plug (Hex): affected from 1.4.0-rc.0; fixed in 1.16.6, 1.17.4, 1.18.5, 1.19.5, 1.20.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-56814/ (Markdown: https://insights.sbomify.com/CVE-2026-56814/index.md)","id":"CVE-2026-56814","markdown":"https://insights.sbomify.com/CVE-2026-56814/index.md","name":"CVE-2026-56814","record":{"aliases":["EEF-CVE-2026-56814","GHSA-95qv-c9g9-rm63"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Elixir Plug library","requires_auth":"none","summary":"An unauthenticated attacker can cause denial of service by sending multipart requests with many empty file parts, exhausting disk inodes and memory.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"EEF","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Plug.Parsers.MULTIPART, the multipart request-body parser used to handle file uploads and multipart forms, does not enforce its :length budget against all consumed resources, allowing an unauthenticated remote attacker to cause denial of service. The parser charges the :length limit only for part body bytes; part header bytes are never counted, and a part with an empty body costs zero.\n\nBecause every part whose Content-Disposition carries a non-empty filename creates a fresh temporary file (via Plug.Upload) and retains a Plug.Upload struct for the duration of the request, an attacker can send a single request composed of many empty-body file parts. Such a request stays well under the configured :length limit (8,000,000 bytes by default) while creating one temporary file per part, leading to inode and disk exhaustion and unbounded memory growth. Any application using Plug.Parsers with the :multipart parser is affected, and no authentication is required, only reachability of a multipart endpoint over HTTP.\n\nThis vulnerability is associated with program files lib/plug/parsers/multipart.ex and program routines Plug.Parsers.MULTIPART.parse_multipart/2, Plug.Parsers.MULTIPART.parse_multipart_headers/5, Plug.Parsers.MULTIPART.parse_multipart_body/4, and Plug.Parsers.MULTIPART.parse_multipart_file/4.\n\nThis issue affects plug: from 1.4.0-rc.0 before 1.16.6, from 1.17.0 before 1.17.4, from 1.18.0 before 1.18.5, from 1.19.1 before 1.19.5, and from 1.20.0 before 1.20.3.","ecosystems":["Hex"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in plug","id":"CVE-2026-56814","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Hex","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":1,"n_references":10,"next":{"headline":"Path traversal in pwnlift","id":"CVE-2026-56815"},"packages":[{"ecosystem":"Hex","fixed":["1.16.6","1.17.4","1.18.5","1.19.5","1.20.3"],"introduced":["1.4.0-rc.0","1.17.0","1.18.0","1.19.1","1.20.0"],"last_affected":[],"package":"plug","purl":"pkg:hex/plug","source":"EEF-CVE-2026-56814"}],"prev":{"headline":"Cookie attribute injection in Plug.Conn.Cookies.encode/2","id":"CVE-2026-56813"},"products":["plug"],"published":"2026-07-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Erlang Ecosystem Foundation","prefix":"EEF"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-24","vendors":["elixir-plug"]},"summary":"An unauthenticated attacker can cause denial of service by sending multipart requests with many empty file parts, exhausting disk inodes and memory.","url":"https://insights.sbomify.com/CVE-2026-56814/"}