# CVE-2026-56814: Denial of service in plug

> An unauthenticated attacker can cause denial of service by sending multipart requests with many empty file parts, exhausting disk inodes and memory.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2026
- **Updated:** 24 Sep 2026
- **Also known as:** EEF-CVE-2026-56814, GHSA-95qv-c9g9-rm63

## What is CVE-2026-56814?

CVE-2026-56814 is a medium-severity denial of service vulnerability in elixir-plug plug, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Plug.Parsers.MULTIPART, the multipart request-body parser used to handle file uploads and multipart forms, does not enforce its :length budget against all consumed resources, allowing an unauthenticated remote attacker to cause denial of service. The parser charges the :length limit only for part body bytes; part header bytes are never counted, and a part with an empty body costs zero.

Because every part whose Content-Disposition carries a non-empty filename creates a fresh temporary file (via Plug.Upload) and retains a Plug.Upload struct for the duration of the request, an attacker can send a single request composed of many empty-body file parts. Such a request stays well under the configured :length limit (8,000,000 bytes by default) while creating one temporary file per part, leading to inode and disk exhaustion and unbounded memory growth. Any application using Plug.Parsers with the :multipart parser is affected, and no authentication is required, only reachability of a multipart endpoint over HTTP.

This vulnerability is associated with program files lib/plug/parsers/multipart.ex and program routines Plug.Parsers.MULTIPART.parse_multipart/2, Plug.Parsers.MULTIPART.parse_multipart_headers/5, Plug.Parsers.MULTIPART.parse_multipart_body/4, and Plug.Parsers.MULTIPART.parse_multipart_file/4.

This issue affects plug: from 1.4.0-rc.0 before 1.16.6, from 1.17.0 before 1.17.4, from 1.18.0 before 1.18.5, from 1.19.1 before 1.19.5, and from 1.20.0 before 1.20.3.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-56814?

1 open source package ship an affected version, including plug.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plug` | Hex | From 1.4.0-rc.0 | 1.16.6, 1.17.4, 1.18.5, 1.19.5, 1.20.3 |

## How do I fix CVE-2026-56814?

Upgrade plug to a fixed version for your release line: 1.16.6, 1.17.4, 1.18.5 or 1.19.5.

## Is CVE-2026-56814 being exploited?

There is no known exploitation of CVE-2026-56814 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56814 and fix it if it is affected.

What it is: CVE-2026-56814 is a medium-severity denial of service vulnerability in elixir-plug plug, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-56814 in the wild and no public exploit code.

Affected packages and fixed versions:
- plug (Hex): affected from 1.4.0-rc.0; fixed in 1.16.6, 1.17.4, 1.18.5, 1.19.5, 1.20.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56814/ (Markdown: https://insights.sbomify.com/CVE-2026-56814/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56814
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56814
- OSV: https://osv.dev/vulnerability/CVE-2026-56814

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56814/
Summaries are generated and may contain mistakes; the official description above is the record.
