# CVE-2026-56817: Netty: XML External Entity (XXE) injection via unconfigured XML factory when DTD and entity processing are enabled

> Attackers can exploit XML External Entity vulnerabilities in Netty's XmlDecoder if DTD processing is enabled, potentially reading files or causing denial of service.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jul 2026
- **Updated:** 22 Jul 2026
- **Also known as:** CLEANSTART-2026-LD69815, CLEANSTART-2026-TT58644, DEBIAN-CVE-2026-56817, GHSA-4qhr-g3c6-fcfx, MINI-6836-qr6v-5h8g, MINI-77v4-wpr8-2mmj, MINI-7hff-h5vr-gh8q, MINI-g962-w8j6-c6p6, MINI-jqhp-jgvq-f5fh, MINI-m4rr-742j-9pq3, MINI-p3f2-p2r8-hg2v, MINI-ph87-qfqr-577w, MINI-rhv7-xrg3-2562, MINI-v5xm-q4qg-p8j2, UBUNTU-CVE-2026-56817

## What is CVE-2026-56817?

CVE-2026-56817 is a high-severity vulnerability in Netty Netty, published on 21 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Netty is a network application framework for development of protocol servers and clients. In versions 4.2.0.Final through 4.2.15.Final and 4.1.0.Final through 4.1.135.Final, any caller that can deliver bytes to a Netty channel pipeline containing `XmlDecoder` can send XML with a `DOCTYPE` declaration to an `AsyncXMLInputFactory` instantiated with no security configuration, leaving DTD and entity handling active depending on Aalto XML async parser behavior and creating conditional XML external entity risk. This issue is fixed in versions 4.1.136.Final and 4.2.16.Final.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2026-56817?

4 open source packages ship an affected version, including io.netty:netty-codec-xml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty-codec-xml` | Maven | From 4.1.0.Final | 4.1.136.Final |
| `io.netty:netty-codec-xml` | Maven | From 4.1.0.Final | 4.1.136.Final |
| `io.netty:netty-codec-xml` | Maven | From 4.2.0.Final | 4.2.16.Final |
| `io.netty:netty-codec-xml` | Maven | From 4.2.0.Final | 4.2.16.Final |

Products: Netty Netty.

## How do I fix CVE-2026-56817?

Upgrade io.netty:netty-codec-xml to a fixed version for your release line: 4.1.136.Final or 4.2.16.Final.

## Is CVE-2026-56817 being exploited?

There is no known exploitation of CVE-2026-56817 in the wild and no public exploit code.

## Other vulnerabilities in Netty Netty

- [CVE-2026-75595](https://insights.sbomify.com/CVE-2026-75595/): Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext (critical 9.1)
- [CVE-2026-75596](https://insights.sbomify.com/CVE-2026-75596/): Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing (high 8.7)
- [CVE-2026-59901](https://insights.sbomify.com/CVE-2026-59901/): Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang (high 8.7)
- [CVE-2026-55851](https://insights.sbomify.com/CVE-2026-55851/): Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion (high 8.7)
- [CVE-2026-56745](https://insights.sbomify.com/CVE-2026-56745/): Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56817 and fix it if it is affected.

What it is: CVE-2026-56817 is a high-severity vulnerability in Netty Netty, published on 21 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-56817 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.netty:netty-codec-xml (Maven): affected from 4.1.0.Final; fixed in 4.1.136.Final
- io.netty:netty-codec-xml (Maven): affected from 4.1.0.Final; fixed in 4.1.136.Final
- io.netty:netty-codec-xml (Maven): affected from 4.2.0.Final; fixed in 4.2.16.Final
- io.netty:netty-codec-xml (Maven): affected from 4.2.0.Final; fixed in 4.2.16.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56817/ (Markdown: https://insights.sbomify.com/CVE-2026-56817/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56817
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56817
- OSV: https://osv.dev/vulnerability/CVE-2026-56817

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56817/
Summaries are generated and may contain mistakes; the official description above is the record.
