CVE-2026-56818 Netty: RedisArrayAggregator max-elements failure leaves retained partial aggregate state
An unauthenticated peer can retain partial aggregate state and pin pooled buffers by exceeding maxElements, causing resource exhaustion in Netty Redis codec.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-56818?
CVE-2026-56818 is a medium-severity denial of service vulnerability in Netty Netty, published on 7 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Netty is an asynchronous, event-driven network application framework. Prior to 4.1.136.Final and 4.2.16.Final, the RedisArrayAggregator Redis codec clears retained partial aggregate state when the maxNestedArrayDepth limit is exceeded, but it does not clear the same state when the sibling maxElements limit is exceeded. A peer can start a valid RESP array, send a bulk string child, then send a nested array header longer than the configured maxElements. Netty throws a decoder exception in decodeRedisArrayHeader, but the existing partial aggregate remains retained in the handler. If the application leaves the channel alive after the exception, later messages are still consumed into the pre-error aggregate, allowing an unauthenticated peer to keep attacker-controlled aggregate state alive across a security-limit exception and pin retained pooled buffers. This issue is fixed in versions 4.1.136.Final and 4.2.16.Final.
Which versions are affected by CVE-2026-56818?
4 open source packages ship an affected version, including io.netty:netty-codec-redis. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
io.netty:netty-codec-redis Maven | All versions | 4.1.136.Final |
io.netty:netty-codec-redis Maven | All versions | 4.1.136.Final |
io.netty:netty-codec-redis Maven | From 4.2.0-Final | 4.2.16.Final |
io.netty:netty-codec-redis Maven | From 4.2.0-Final | 4.2.16.Final |
Products include Netty Netty.
How do I fix CVE-2026-56818?
Upgrade io.netty:netty-codec-redis to a fixed version for your release line: 4.1.136.Final or 4.2.16.Final.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-56818 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56818 exists.
Other vulnerabilities in Netty Netty
- CVE-2026-75595 Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext
- CVE-2026-75596 Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing
- CVE-2026-59901 Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang
- CVE-2026-55851 Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion
- CVE-2026-56745 Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion
Sources
Also known as DEBIAN-CVE-2026-56818, GHSA-p9jm-q85p-7mcp, MINI-235v-vhh2-gh26, MINI-2xc4-566w-64j8, MINI-3f9m-fmh3-wfmx, MINI-87jq-g97c-hqjj and 7 more.