# CVE-2026-56818: Netty: RedisArrayAggregator max-elements failure leaves retained partial aggregate state

> An unauthenticated peer can retain partial aggregate state and pin pooled buffers by exceeding maxElements, causing resource exhaustion in Netty Redis codec.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Aug 2026
- **Updated:** 8 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-56818, GHSA-p9jm-q85p-7mcp, MINI-235v-vhh2-gh26, MINI-2xc4-566w-64j8, MINI-3f9m-fmh3-wfmx, MINI-87jq-g97c-hqjj, MINI-95g3-942v-xpg5, MINI-9v75-586m-v599, MINI-fvfg-wf9p-hrv3, MINI-qp6m-9c5m-26h7, MINI-xwc3-p7mf-w5v3, MINI-xxxx-6f7r-x43r, UBUNTU-CVE-2026-56818

## What is CVE-2026-56818?

CVE-2026-56818 is a medium-severity denial of service vulnerability in Netty Netty, published on 7 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Netty is an asynchronous, event-driven network application framework. Prior to 4.1.136.Final and 4.2.16.Final, the RedisArrayAggregator Redis codec clears retained partial aggregate state when the maxNestedArrayDepth limit is exceeded, but it does not clear the same state when the sibling maxElements limit is exceeded. A peer can start a valid RESP array, send a bulk string child, then send a nested array header longer than the configured maxElements. Netty throws a decoder exception in decodeRedisArrayHeader, but the existing partial aggregate remains retained in the handler. If the application leaves the channel alive after the exception, later messages are still consumed into the pre-error aggregate, allowing an unauthenticated peer to keep attacker-controlled aggregate state alive across a security-limit exception and pin retained pooled buffers. This issue is fixed in versions 4.1.136.Final and 4.2.16.Final.

Weakness: CWE-703 (Improper Check or Handling of Exceptional Conditions), CWE-401 (Missing Release of Memory after Effective Lifetime)

## Which versions are affected by CVE-2026-56818?

4 open source packages ship an affected version, including io.netty:netty-codec-redis. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty-codec-redis` | Maven | All versions | 4.1.136.Final |
| `io.netty:netty-codec-redis` | Maven | All versions | 4.1.136.Final |
| `io.netty:netty-codec-redis` | Maven | From 4.2.0-Final | 4.2.16.Final |
| `io.netty:netty-codec-redis` | Maven | From 4.2.0-Final | 4.2.16.Final |

Products: Netty Netty.

## How do I fix CVE-2026-56818?

Upgrade io.netty:netty-codec-redis to a fixed version for your release line: 4.1.136.Final or 4.2.16.Final.

## Is CVE-2026-56818 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56818 exists.

## Other vulnerabilities in Netty Netty

- [CVE-2026-75595](https://insights.sbomify.com/CVE-2026-75595/): Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext (critical 9.1)
- [CVE-2026-75596](https://insights.sbomify.com/CVE-2026-75596/): Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing (high 8.7)
- [CVE-2026-59901](https://insights.sbomify.com/CVE-2026-59901/): Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang (high 8.7)
- [CVE-2026-55851](https://insights.sbomify.com/CVE-2026-55851/): Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion (high 8.7)
- [CVE-2026-56745](https://insights.sbomify.com/CVE-2026-56745/): Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56818 and fix it if it is affected.

What it is: CVE-2026-56818 is a medium-severity denial of service vulnerability in Netty Netty, published on 7 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56818 exists.

Affected packages and fixed versions:
- io.netty:netty-codec-redis (Maven): affected all versions; fixed in 4.1.136.Final
- io.netty:netty-codec-redis (Maven): affected all versions; fixed in 4.1.136.Final
- io.netty:netty-codec-redis (Maven): affected from 4.2.0-Final; fixed in 4.2.16.Final
- io.netty:netty-codec-redis (Maven): affected from 4.2.0-Final; fixed in 4.2.16.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56818/ (Markdown: https://insights.sbomify.com/CVE-2026-56818/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56818
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56818
- OSV: https://osv.dev/vulnerability/CVE-2026-56818

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56818/
Summaries are generated and may contain mistakes; the official description above is the record.
