CVE-2026-56821 Netty: Out-of-date OCSP Responses Accepted by OcspServerCertificateValidator
An on-path attacker can bypass certificate revocation checks by replaying expired OCSP responses, allowing revoked certificates to be accepted.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-56821?
CVE-2026-56821 is a high-severity vulnerability in Netty Netty, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, the OcspServerCertificateValidator flags an out-of-date OCSP response but does not stop processing it, so an expired GOOD response is still reported as VALID, letting an on-path attacker replay a stale GOOD response to bypass revocation of a since-revoked certificate. Exploitation can lead to certificate revocation bypass via replay of an expired OCSP response. Any application using OcspServerCertificateValidator is affected; a revoked certificate can be accepted. This issue has been fixed in versions 4.1.136.Final and 4.2.16.Final.
Weakness: CWE-299
Which versions are affected by CVE-2026-56821?
4 open source packages ship an affected version, including io.netty:netty-handler-ssl-ocsp. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
io.netty:netty-handler-ssl-ocsp Maven | All versions | 4.1.136.Final |
io.netty:netty-handler-ssl-ocsp Maven | All versions | 4.1.136.Final |
io.netty:netty-handler-ssl-ocsp Maven | From 4.2.0.Final | 4.2.16.Final |
io.netty:netty-handler-ssl-ocsp Maven | From 4.2.0.Final | 4.2.16.Final |
Products include Netty Netty.
How do I fix CVE-2026-56821?
Upgrade io.netty:netty-handler-ssl-ocsp to a fixed version for your release line: 4.1.136.Final or 4.2.16.Final.
Is CVE-2026-56821 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56821 exists.
Other vulnerabilities in Netty Netty
- CVE-2026-75595 Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext
- CVE-2026-75596 Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing
- CVE-2026-59901 Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang
- CVE-2026-55851 Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion
- CVE-2026-56745 Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion
Sources
Also known as CLEANSTART-2026-PX19443, CLEANSTART-2026-ZL96278, DEBIAN-CVE-2026-56821, ECHO-ff9e-bb84-4e6f, GHSA-g7hg-vrcf-mvmr, MINI-263c-frj3-4m39 and 10 more.