# CVE-2026-56821: Netty: Out-of-date OCSP Responses Accepted by OcspServerCertificateValidator

> An on-path attacker can bypass certificate revocation checks by replaying expired OCSP responses, allowing revoked certificates to be accepted.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jul 2026
- **Updated:** 31 Jul 2026
- **Also known as:** CLEANSTART-2026-PX19443, CLEANSTART-2026-ZL96278, DEBIAN-CVE-2026-56821, ECHO-ff9e-bb84-4e6f, GHSA-g7hg-vrcf-mvmr, MINI-263c-frj3-4m39, MINI-6v6p-qw2p-fh4j, MINI-7m24-8f7v-j7q5, MINI-8jc3-54wc-w96q, MINI-9x2m-6575-8gxr, MINI-c527-2fg8-4f33, MINI-f625-frpw-cv28, MINI-q45f-2w84-7rxr, MINI-r37f-q2f9-2765, MINI-w47h-frvp-vpwm, UBUNTU-CVE-2026-56821

## What is CVE-2026-56821?

CVE-2026-56821 is a high-severity vulnerability in Netty Netty, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, the OcspServerCertificateValidator flags an out-of-date OCSP response but does not stop processing it, so an expired GOOD response is still reported as VALID, letting an on-path attacker replay a stale GOOD response to bypass revocation of a since-revoked certificate. Exploitation can lead to certificate revocation bypass via replay of an expired OCSP response. Any application using OcspServerCertificateValidator is affected; a revoked certificate can be accepted. This issue has been fixed in versions 4.1.136.Final and 4.2.16.Final.

Weakness: CWE-299 (Improper Check for Certificate Revocation)

## Which versions are affected by CVE-2026-56821?

4 open source packages ship an affected version, including io.netty:netty-handler-ssl-ocsp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty-handler-ssl-ocsp` | Maven | All versions | 4.1.136.Final |
| `io.netty:netty-handler-ssl-ocsp` | Maven | All versions | 4.1.136.Final |
| `io.netty:netty-handler-ssl-ocsp` | Maven | From 4.2.0.Final | 4.2.16.Final |
| `io.netty:netty-handler-ssl-ocsp` | Maven | From 4.2.0.Final | 4.2.16.Final |

Products: Netty Netty.

## How do I fix CVE-2026-56821?

Upgrade io.netty:netty-handler-ssl-ocsp to a fixed version for your release line: 4.1.136.Final or 4.2.16.Final.

## Is CVE-2026-56821 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56821 exists.

## Other vulnerabilities in Netty Netty

- [CVE-2026-75595](https://insights.sbomify.com/CVE-2026-75595/): Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext (critical 9.1)
- [CVE-2026-75596](https://insights.sbomify.com/CVE-2026-75596/): Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing (high 8.7)
- [CVE-2026-59901](https://insights.sbomify.com/CVE-2026-59901/): Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang (high 8.7)
- [CVE-2026-55851](https://insights.sbomify.com/CVE-2026-55851/): Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion (high 8.7)
- [CVE-2026-56745](https://insights.sbomify.com/CVE-2026-56745/): Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56821 and fix it if it is affected.

What it is: CVE-2026-56821 is a high-severity vulnerability in Netty Netty, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56821 exists.

Affected packages and fixed versions:
- io.netty:netty-handler-ssl-ocsp (Maven): affected all versions; fixed in 4.1.136.Final
- io.netty:netty-handler-ssl-ocsp (Maven): affected all versions; fixed in 4.1.136.Final
- io.netty:netty-handler-ssl-ocsp (Maven): affected from 4.2.0.Final; fixed in 4.2.16.Final
- io.netty:netty-handler-ssl-ocsp (Maven): affected from 4.2.0.Final; fixed in 4.2.16.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56821/ (Markdown: https://insights.sbomify.com/CVE-2026-56821/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56821
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56821
- OSV: https://osv.dev/vulnerability/CVE-2026-56821

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56821/
Summaries are generated and may contain mistakes; the official description above is the record.
