CVE-2026-56822 Netty: TOCTOU in OcspServerCertificateValidator
Attackers can exploit a race condition in Netty's OCSP validator to leak sensitive data to revoked servers before the connection is closed.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-56822?
CVE-2026-56822 is a high-severity vulnerability in Netty Netty, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, the OcspServerCertificateValidator forwards the SslHandshakeCompletionEvent before the asynchronous OCSP validation completes. This allows the client's downstream handlers to send sensitive application data (e.g., HTTP requests) to a revoked server before the channel is closed by the OCSP check. n io.netty.handler.ssl.ocsp.OcspServerCertificateValidator#userEventTriggered, when an SslHandshakeCompletionEvent is received, the validator immediately calls ctx.fireUserEventTriggered(evt). It then initiates an asynchronous OCSP query using OcspClient.query. Because the handshake completion event is forwarded immediately, downstream handlers in the client's pipeline are notified that the TLS handshake is successful. They may then begin reading and processing incoming application data or sending outgoing data. If the OCSP response later indicates the server's certificate is REVOKED, the validator closes the channel, but by this time, the client may have already leaked sensitive data to a revoked server or processed malicious responses from it. This issue has been fixed in versions 4.1.136.Final and 4.2.16.Final.
Weakness: CWE-367
Which versions are affected by CVE-2026-56822?
4 open source packages ship an affected version, including io.netty:netty-handler-ssl-ocsp. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
io.netty:netty-handler-ssl-ocsp Maven | All versions | 4.1.136.Final |
io.netty:netty-handler-ssl-ocsp Maven | All versions | 4.1.136.Final |
io.netty:netty-handler-ssl-ocsp Maven | From 4.2.0.Final | 4.2.16.Final |
io.netty:netty-handler-ssl-ocsp Maven | From 4.2.0.Final | 4.2.16.Final |
Products include Netty Netty.
How do I fix CVE-2026-56822?
Upgrade io.netty:netty-handler-ssl-ocsp to a fixed version for your release line: 4.1.136.Final or 4.2.16.Final.
Is CVE-2026-56822 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56822 exists.
Other vulnerabilities in Netty Netty
- CVE-2026-75595 Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext
- CVE-2026-75596 Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing
- CVE-2026-59901 Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang
- CVE-2026-55851 Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion
- CVE-2026-56745 Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion
Sources
Also known as CLEANSTART-2026-DF40874, CLEANSTART-2026-RU96271, DEBIAN-CVE-2026-56822, ECHO-b0f9-ed1f-4fd2, GHSA-wc96-39fc-566f, MINI-4jfh-3j3g-9gqj and 10 more.