# CVE-2026-56825: Shopper: Missing authorization on product removal actions in CollectionProducts component

> Authenticated staff users can remove products from arbitrary collections due to missing authorization checks in the CollectionProducts component.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-2cg9-97gq-9mqp

## What is CVE-2026-56825?

CVE-2026-56825 is a high-severity missing authorization vulnerability in shopperlabs shopper, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Shopper is a Headless e-commerce Admin Panel. Prior to 2.9.2, packages/admin/src/Livewire/Components/Collection/CollectionProducts.php exposes Action::make('delete') and DeleteBulkAction::make() without delete_collections authorization, while public Collection $collection remains client mutable because it lacks the Livewire Locked attribute. An authenticated staff user with only browse_collections can invoke a Livewire removal action, substitute an arbitrary collection identifier, and detach selected products or empty the collection. This can disrupt catalog landing pages and promotions associated with the targeted collection. This issue is fixed in version 2.9.2.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-56825?

2 open source packages ship an affected version, including shopper/framework.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopper/framework` | Packagist | All versions | 2.9.2 |
| `shopper/framework` | Packagist | All versions | 2.9.2 |

## How do I fix CVE-2026-56825?

Upgrade shopper/framework to 2.9.2 or later.

## Is CVE-2026-56825 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56825 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56825 and fix it if it is affected.

What it is: CVE-2026-56825 is a high-severity missing authorization vulnerability in shopperlabs shopper, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56825 exists.

Affected packages and fixed versions:
- shopper/framework (Packagist): affected all versions; fixed in 2.9.2
- shopper/framework (Packagist): affected all versions; fixed in 2.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56825/ (Markdown: https://insights.sbomify.com/CVE-2026-56825/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56825
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56825
- OSV: https://osv.dev/vulnerability/CVE-2026-56825

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56825/
Summaries are generated and may contain mistakes; the official description above is the record.
