# CVE-2026-56826: Shopping privilege escalation through missing authorization in Settings components

> Low-privileged users can delete critical commerce configuration settings like shipping zones and tax rates due to missing server-side authorization checks.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Oct 2026
- **Updated:** 17 Oct 2026
- **Also known as:** GHSA-f7h9-qv4x-9x57

## What is CVE-2026-56826?

CVE-2026-56826 is a medium-severity missing authorization vulnerability in shopperlabs shopper, published on 13 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Shopper is a Headless e-commerce Admin Panel. From 2.0.0 until 2.9.2, authenticated users who could reach the Settings pages with only access_setting could directly invoke destructive actions through the Livewire endpoint because packages/admin/src/Livewire/Components/Settings/Zones/ZoneShippingOptions.php, packages/admin/src/Livewire/Components/Settings/Zones/Detail.php, packages/admin/src/Livewire/Components/Settings/Taxes/Detail.php, and packages/admin/src/Livewire/Components/Settings/Taxes/TaxRates.php did not enforce server-side delete authorization. The actions could delete carrier options, shipping zones, tax zones, and tax rates, disrupting checkout shipping, payment-method mapping, and tax calculation. This issue is fixed in version 2.9.2.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-56826?

2 open source packages ship an affected version, including shopper/framework.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopper/framework` | Packagist | From 2.0.0 | 2.9.2 |
| `shopper/framework` | Packagist | From 2.0.0 | 2.9.2 |

## How do I fix CVE-2026-56826?

Upgrade shopper/framework to 2.9.2 or later.

## Is CVE-2026-56826 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56826 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56826 and fix it if it is affected.

What it is: CVE-2026-56826 is a medium-severity missing authorization vulnerability in shopperlabs shopper, published on 13 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56826 exists.

Affected packages and fixed versions:
- shopper/framework (Packagist): affected from 2.0.0; fixed in 2.9.2
- shopper/framework (Packagist): affected from 2.0.0; fixed in 2.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56826/ (Markdown: https://insights.sbomify.com/CVE-2026-56826/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56826
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56826
- OSV: https://osv.dev/vulnerability/CVE-2026-56826

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56826/
Summaries are generated and may contain mistakes; the official description above is the record.
