# CVE-2026-56829: Shopper: Unauthorized inventory stock manipulation via unlocked variant property in VariantStock component

> Authenticated staff with browse-only permissions can manipulate inventory stock levels for arbitrary product variants due to missing authorization checks.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 15 Sep 2026
- **Also known as:** GHSA-g3f9-g5vj-p62f

## What is CVE-2026-56829?

CVE-2026-56829 is a high-severity missing authorization vulnerability in shopperlabs shopper, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Shopper is a Headless e-commerce Admin Panel. Prior to 2.9.2, packages/admin/src/Livewire/Components/Products/VariantStock.php exposes stockAction() without edit_product_variants authorization and leaves public $variant client mutable because it lacks the Livewire Locked attribute. Any authenticated admin-panel user, including staff with only browse_products, can select an arbitrary product variant and inventory location through component state, then submit a positive or negative quantity adjustment. This permits browse-only staff to inflate stock, reduce stock, or force out-of-stock states for variants outside the current page. This issue is fixed in version 2.9.2.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-56829?

2 open source packages ship an affected version, including shopper/framework.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopper/framework` | Packagist | All versions | 2.9.2 |
| `shopper/framework` | Packagist | All versions | 2.9.2 |

## How do I fix CVE-2026-56829?

Upgrade shopper/framework to 2.9.2 or later.

## Is CVE-2026-56829 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56829 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56829 and fix it if it is affected.

What it is: CVE-2026-56829 is a high-severity missing authorization vulnerability in shopperlabs shopper, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56829 exists.

Affected packages and fixed versions:
- shopper/framework (Packagist): affected all versions; fixed in 2.9.2
- shopper/framework (Packagist): affected all versions; fixed in 2.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56829/ (Markdown: https://insights.sbomify.com/CVE-2026-56829/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56829
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56829
- OSV: https://osv.dev/vulnerability/CVE-2026-56829

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56829/
Summaries are generated and may contain mistakes; the official description above is the record.
