# CVE-2026-56830: Shopper: Incomplete fix for GHSA-h4mp-g9c6-xwph: Media sub-form store() still lacks authorization

> Authenticated staff users can modify product images without edit permissions due to a missing authorization check in the media sub-form.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 15 Sep 2026
- **Also known as:** GHSA-99h5-jhh7-v3r3

## What is CVE-2026-56830?

CVE-2026-56830 is a medium-severity missing authorization vulnerability in shopperlabs shopper, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Shopper is a Headless e-commerce Admin Panel. Prior to 2.9.2, an earlier product sub-form hardening change left store() in packages/admin/src/Livewire/Components/Products/Form/Media.php without the edit_products authorization check used by sibling sub-forms. An authenticated staff user with browse_products can invoke the Livewire store action and replace the thumbnail and gallery images for a product whose Media component was initialized, even without product-edit permission. The product binding is locked, so the attacker cannot redirect the update to an arbitrary product through client-side ID substitution, and the impact is limited to products whose edit pages were loaded. This issue is fixed in version 2.9.2.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-56830?

2 open source packages ship an affected version, including shopper/framework.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopper/framework` | Packagist | All versions | 2.9.2 |
| `shopper/framework` | Packagist | All versions | 2.9.2 |

## How do I fix CVE-2026-56830?

Upgrade shopper/framework to 2.9.2 or later.

## Is CVE-2026-56830 being exploited?

There is no known exploitation of CVE-2026-56830 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56830 and fix it if it is affected.

What it is: CVE-2026-56830 is a medium-severity missing authorization vulnerability in shopperlabs shopper, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-56830 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopper/framework (Packagist): affected all versions; fixed in 2.9.2
- shopper/framework (Packagist): affected all versions; fixed in 2.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56830/ (Markdown: https://insights.sbomify.com/CVE-2026-56830/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56830
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56830
- OSV: https://osv.dev/vulnerability/CVE-2026-56830

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56830/
Summaries are generated and may contain mistakes; the official description above is the record.
