# CVE-2026-56831: Shopper: Negative discount values accepted and propagated through order calculation pipeline

> Administrators can create negative discounts that incorrectly increase order totals, compromising financial data integrity in the Shopper e-commerce platform.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-5vf4-452p-jjhf

## What is CVE-2026-56831?

CVE-2026-56831 is a medium-severity vulnerability in shopperlabs shopper, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Shopper is a Headless e-commerce Admin Panel. Prior to 2.9.0, the /cpanel/discounts administrative interface accepts negative fixed_amount discount values, persists them in sh_discounts, and passes them through vendor/shopper/cart/src/Discounts/DiscountCalculator.php and vendor/shopper/cart/src/Pipelines/Calculate.php without enforcing a positive-value invariant. Because the calculation subtracts discountTotal from the subtotal, a negative discount increases the resulting order total instead of reducing it. Malformed discount records can therefore cause incorrect pricing and financial data integrity failures, although the advisory does not establish a customer-facing exploitation path. This issue is fixed in version 2.9.0.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-56831?

2 open source packages ship an affected version, including shopper/framework.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopper/framework` | Packagist | All versions | 2.9.0 |
| `shopper/framework` | Packagist | All versions | 2.9.0 |

## How do I fix CVE-2026-56831?

Upgrade shopper/framework to 2.9.0 or later.

## Is CVE-2026-56831 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56831 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56831 and fix it if it is affected.

What it is: CVE-2026-56831 is a medium-severity vulnerability in shopperlabs shopper, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56831 exists.

Affected packages and fixed versions:
- shopper/framework (Packagist): affected all versions; fixed in 2.9.0
- shopper/framework (Packagist): affected all versions; fixed in 2.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56831/ (Markdown: https://insights.sbomify.com/CVE-2026-56831/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56831
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56831
- OSV: https://osv.dev/vulnerability/CVE-2026-56831

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56831/
Summaries are generated and may contain mistakes; the official description above is the record.
