# CVE-2026-56834: PraisonAI dynamic-context artifact tools read arbitrary host files outside artifact storage


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-j7qx-p75m-wp7g, PYSEC-2026-3514

## What is CVE-2026-56834?

CVE-2026-56834 is a high-severity vulnerability in MervinPraison PraisonAI, published on 23 Oct 2026. 

### Official description

PraisonAI is a multi-agent teams system. From version 3.8.1 to before version 4.6.59, PraisonAI's Dynamic Context Discovery feature exposes artifact helper tools through ctx.get_tools(). The implemented artifact tools do not enforce that the supplied artifact_path is an artifact created by the configured store or that it lives under the configured artifact base directory. Instead, artifact_head, artifact_tail, artifact_grep, and artifact_chunk wrap the caller-supplied path directly into an ArtifactRef and then read it from the host filesystem. As a result, any prompt/user/tool-caller that can influence those tool arguments can read files readable by the PraisonAI process, such as project .env files, cloud credentials, SSH keys, source files, or other local data. This issue has been patched in version 4.6.59.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-56834?

3 open source packages ship an affected version, including praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | From 3.8.1 | 4.6.59 |
| `praisonai` | PyPI | From 3.8.1 | 4.6.59 |
| `praisonai` | PyPI | From 3.8.1 | 4.6.59 |

## How do I fix CVE-2026-56834?

Upgrade praisonai to 4.6.59 or later.

## Is CVE-2026-56834 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56834 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56834 and fix it if it is affected.

What it is: CVE-2026-56834 is a high-severity vulnerability in MervinPraison PraisonAI, published on 23 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56834 exists.

Affected packages and fixed versions:
- praisonai (PyPI): affected from 3.8.1; fixed in 4.6.59
- praisonai (PyPI): affected from 3.8.1; fixed in 4.6.59
- praisonai (PyPI): affected from 3.8.1; fixed in 4.6.59

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56834/ (Markdown: https://insights.sbomify.com/CVE-2026-56834/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56834
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56834
- OSV: https://osv.dev/vulnerability/CVE-2026-56834

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56834/
Summaries are generated and may contain mistakes; the official description above is the record.
