# CVE-2026-56835: PraisonAI Slack app_mention bypasses configured user/channel authorization


- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-qvpf-j64c-jmhr, PYSEC-2026-3518

## What is CVE-2026-56835?

CVE-2026-56835 is a high-severity vulnerability in MervinPraison PraisonAI, published on 23 Oct 2026. 

### Official description

PraisonAI is a multi-agent teams system. From version 3.11.0 to before version 4.6.59, PraisonAI's Slack bot applies its configured allowed_users, allowed_channels, and unknown-user pairing policy in the normal Slack message event handler, but not in the adjacent Slack app_mention event handler. A Slack workspace user who can mention the bot in a channel where the Slack app is present can trigger the configured PraisonAI agent even when: the sender is not in BotConfig.allowed_users; the channel is not in BotConfig.allowed_channels; unknown_user_policy="deny" is configured; and the same event content is correctly dropped by the normal message handler. This issue has been patched in version 4.6.59.

Weakness: CWE-863 (Incorrect Authorization), CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-56835?

3 open source packages ship an affected version, including praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | From 3.11.0 | 4.6.59 |
| `praisonai` | PyPI | From 3.11.0 | 4.6.59 |
| `praisonai` | PyPI | From 3.11.0 | 4.6.59 |

## How do I fix CVE-2026-56835?

Upgrade praisonai to 4.6.59 or later.

## Is CVE-2026-56835 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56835 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56835 and fix it if it is affected.

What it is: CVE-2026-56835 is a high-severity vulnerability in MervinPraison PraisonAI, published on 23 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56835 exists.

Affected packages and fixed versions:
- praisonai (PyPI): affected from 3.11.0; fixed in 4.6.59
- praisonai (PyPI): affected from 3.11.0; fixed in 4.6.59
- praisonai (PyPI): affected from 3.11.0; fixed in 4.6.59

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56835/ (Markdown: https://insights.sbomify.com/CVE-2026-56835/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56835
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56835
- OSV: https://osv.dev/vulnerability/CVE-2026-56835

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56835/
Summaries are generated and may contain mistakes; the official description above is the record.
