# CVE-2026-56836: PraisonAI recipe serve Typer command bypasses the non-localhost authentication guard


- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** GHSA-5qw8-f2g9-ff29, PYSEC-2026-3502

## What is CVE-2026-56836?

CVE-2026-56836 is a high-severity vulnerability in MervinPraison PraisonAI, published on 23 Oct 2026. 

### Official description

PraisonAI is a multi-agent teams system. From version 4.5.112 to before version 4.6.59, PraisonAI's installed console entrypoint is Typer-first. In current releases, the recipe command is registered in the Typer app and praisonai recipe serve dispatches to the deprecated Typer command in src/praisonai/praisonai/cli/commands/recipe.py. That Typer command can start the Recipe HTTP server on a non-localhost interface with no authentication. It prints a deprecation warning, and then launches the server. Because config.auth is absent, create_app() does not attach the API-key or JWT middleware. Unauthenticated requests can then reach the recipe API and, when enabled, /admin/reload. This issue has been patched in version 4.6.59.

Weakness: CWE-862 (Missing Authorization), CWE-306 (Missing Authentication for Critical Functionality), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-56836?

3 open source packages ship an affected version, including praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | From 4.5.112 | 4.6.59 |
| `praisonai` | PyPI | From 4.5.112 | 4.6.59 |
| `praisonai` | PyPI | From 4.5.112 | 4.6.59 |

## How do I fix CVE-2026-56836?

Upgrade praisonai to 4.6.59 or later.

## Is CVE-2026-56836 being exploited?

There is no known exploitation of CVE-2026-56836 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56836 and fix it if it is affected.

What it is: CVE-2026-56836 is a high-severity vulnerability in MervinPraison PraisonAI, published on 23 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-56836 in the wild and no public exploit code.

Affected packages and fixed versions:
- praisonai (PyPI): affected from 4.5.112; fixed in 4.6.59
- praisonai (PyPI): affected from 4.5.112; fixed in 4.6.59
- praisonai (PyPI): affected from 4.5.112; fixed in 4.6.59

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56836/ (Markdown: https://insights.sbomify.com/CVE-2026-56836/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56836
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56836
- OSV: https://osv.dev/vulnerability/CVE-2026-56836

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56836/
Summaries are generated and may contain mistakes; the official description above is the record.
