CVE-2026-56838 PraisonAI recipe.run_stream skips dangerous-tool policy enforcement

High 7.8 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2026-56838?

CVE-2026-56838 is a high-severity vulnerability in MervinPraison PraisonAI, published on 23 Oct 2026.

Official description

PraisonAI is a multi-agent teams system. From version 4.5.87 to before version 4.6.59, PraisonAI recipe execution blocks default-denied dangerous tools unless the caller explicitly passes allow_dangerous_tools=True. The normal recipe.run() path enforces this with _check_tool_policy(). The streaming path, recipe.run_stream(), loads the same recipe, checks dependencies, and then calls _execute_recipe() without running the dangerous-tool policy check. As a result, a recipe that honestly declares execute_command in TEMPLATE.yaml requires.tools is denied by recipe.run(), but reaches the execution engine through recipe.run_stream() with allow_dangerous_tools=False. This issue has been patched in version 4.6.59.

Weakness: CWE-863, CWE-78, CWE-693

Which versions are affected by CVE-2026-56838?

3 open source packages ship an affected version, including praisonai.

PackageAffectedFixed in
praisonai PyPIFrom 4.5.874.6.59
praisonai PyPIFrom 4.5.874.6.59
praisonai PyPIFrom 4.5.874.6.59

How do I fix CVE-2026-56838?

Upgrade praisonai to 4.6.59 or later.

Is CVE-2026-56838 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56838 exists.

Sources

Also known as GHSA-v847-hxxw-3pxg, PYSEC-2026-3520.

Is CVE-2026-56838 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free