# CVE-2026-56838: PraisonAI recipe.run_stream skips dangerous-tool policy enforcement


- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-v847-hxxw-3pxg, PYSEC-2026-3520

## What is CVE-2026-56838?

CVE-2026-56838 is a high-severity vulnerability in MervinPraison PraisonAI, published on 23 Oct 2026. 

### Official description

PraisonAI is a multi-agent teams system. From version 4.5.87 to before version 4.6.59, PraisonAI recipe execution blocks default-denied dangerous tools unless the caller explicitly passes allow_dangerous_tools=True. The normal recipe.run() path enforces this with _check_tool_policy(). The streaming path, recipe.run_stream(), loads the same recipe, checks dependencies, and then calls _execute_recipe() without running the dangerous-tool policy check. As a result, a recipe that honestly declares execute_command in TEMPLATE.yaml requires.tools is denied by recipe.run(), but reaches the execution engine through recipe.run_stream() with allow_dangerous_tools=False. This issue has been patched in version 4.6.59.

Weakness: CWE-863 (Incorrect Authorization), CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-56838?

3 open source packages ship an affected version, including praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | From 4.5.87 | 4.6.59 |
| `praisonai` | PyPI | From 4.5.87 | 4.6.59 |
| `praisonai` | PyPI | From 4.5.87 | 4.6.59 |

## How do I fix CVE-2026-56838?

Upgrade praisonai to 4.6.59 or later.

## Is CVE-2026-56838 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56838 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56838 and fix it if it is affected.

What it is: CVE-2026-56838 is a high-severity vulnerability in MervinPraison PraisonAI, published on 23 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56838 exists.

Affected packages and fixed versions:
- praisonai (PyPI): affected from 4.5.87; fixed in 4.6.59
- praisonai (PyPI): affected from 4.5.87; fixed in 4.6.59
- praisonai (PyPI): affected from 4.5.87; fixed in 4.6.59

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56838/ (Markdown: https://insights.sbomify.com/CVE-2026-56838/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56838
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56838
- OSV: https://osv.dev/vulnerability/CVE-2026-56838

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56838/
Summaries are generated and may contain mistakes; the official description above is the record.
