# CVE-2026-56839: PraisonAI Code agent tools fail open without a workspace boundary

> Attackers can read and modify files outside the intended directory if code tools are used before setting a workspace boundary.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-gcq3-mfvh-3x25, PYSEC-2026-3512

## What is CVE-2026-56839?

CVE-2026-56839 is a high-severity path traversal vulnerability in MervinPraison PraisonAI, published on 14 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

PraisonAI is a multi-agent teams system. Prior to 4.6.59, the CODE_TOOLS wrappers keep _workspace_root as None and pass workspace=None to read_file, search_replace, and apply_diff helpers that enforce path containment only for a truthy workspace. An application that exposes code_read_file, code_search_replace, or code_apply_diff before set_workspace can therefore let prompt-influenced calls read and modify files outside the intended project directory, while explicitly configured workspaces remain effective. This vulnerability is fixed in 4.6.59.

Weakness: CWE-863 (Incorrect Authorization), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-56839?

3 open source packages ship an affected version, including praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | All versions | 4.6.59 |
| `praisonai` | PyPI | All versions | 4.6.59 |
| `praisonai` | PyPI | All versions | 4.6.59 |

## How do I fix CVE-2026-56839?

Upgrade praisonai to 4.6.59 or later.

## Is CVE-2026-56839 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56839 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56839 and fix it if it is affected.

What it is: CVE-2026-56839 is a high-severity path traversal vulnerability in MervinPraison PraisonAI, published on 14 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56839 exists.

Affected packages and fixed versions:
- praisonai (PyPI): affected all versions; fixed in 4.6.59
- praisonai (PyPI): affected all versions; fixed in 4.6.59
- praisonai (PyPI): affected all versions; fixed in 4.6.59

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56839/ (Markdown: https://insights.sbomify.com/CVE-2026-56839/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56839
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56839
- OSV: https://osv.dev/vulnerability/CVE-2026-56839

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56839/
Summaries are generated and may contain mistakes; the official description above is the record.
