# CVE-2026-56840: PraisonAI: HTTPApproval dashboard renders tool arguments as raw HTML, allowing approval-page XSS to approve dangerous tools


- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-63v4-w882-g4x2, PYSEC-2026-3503

## What is CVE-2026-56840?

CVE-2026-56840 is a high-severity vulnerability in MervinPraison PraisonAI, published on 23 Oct 2026. 

### Official description

PraisonAI is a multi-agent teams system. From version 4.5.2 to before version 4.6.59, praisonai.bots.HTTPApproval renders pending tool approval arguments directly into the approval dashboard HTML. An attacker-controlled tool argument can inject JavaScript into that page. When a human opens the approval URL to inspect the risky tool request, the script runs in the dashboard origin and can POST to the same request's /approve/{request_id}/decide endpoint, causing HTTPApproval to return approved=True. This issue has been patched in version 4.6.59.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-56840?

3 open source packages ship an affected version, including praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | From 4.5.2 | 4.6.59 |
| `praisonai` | PyPI | From 4.5.2 | 4.6.59 |
| `praisonai` | PyPI | From 4.5.2 | 4.6.59 |

## How do I fix CVE-2026-56840?

Upgrade praisonai to 4.6.59 or later.

## Is CVE-2026-56840 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56840 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56840 and fix it if it is affected.

What it is: CVE-2026-56840 is a high-severity vulnerability in MervinPraison PraisonAI, published on 23 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56840 exists.

Affected packages and fixed versions:
- praisonai (PyPI): affected from 4.5.2; fixed in 4.6.59
- praisonai (PyPI): affected from 4.5.2; fixed in 4.6.59
- praisonai (PyPI): affected from 4.5.2; fixed in 4.6.59

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56840/ (Markdown: https://insights.sbomify.com/CVE-2026-56840/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56840
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56840
- OSV: https://osv.dev/vulnerability/CVE-2026-56840

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56840/
Summaries are generated and may contain mistakes; the official description above is the record.
