{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2026-56968 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-56968 is a low-severity vulnerability in Debian Debian Linux, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-56968 and fix it if it is affected.\n\nWhat it is: CVE-2026-56968 is a low-severity vulnerability in Debian Debian Linux, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-56968 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-56968/ (Markdown: https://insights.sbomify.com/CVE-2026-56968/index.md)","id":"CVE-2026-56968","markdown":"https://insights.sbomify.com/CVE-2026-56968/index.md","name":"CVE-2026-56968","record":{"aliases":["DEBIAN-CVE-2026-56968","GHSA-2qgp-6c6g-cmwv","SUSE-SU-2026:22631-1","UBUNTU-CVE-2026-56968","openSUSE-SU-2026:21303-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"GNU SASL library","requires_auth":"none","summary":"A crafted server can trigger memory disclosure in the GNU SASL NTLM client due to lack of sanitization, potentially exposing sensitive data.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"sasl","vendor":"gnu"}],"cvss":{"score":3.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-908","name":"Use of Uninitialized Resource"},{"id":"CWE-839","name":"Numeric Range Comparison Without Minimum Check"}],"description":"GNU SASL before 2.2.4 lacks sanitization of a short challenge in _gsasl_ntlm_client_step in the NTLM client, which could result in memory disclosure via a crafted server.","ecosystems":["SUSE:Linux Enterprise Server 16.0","SUSE:Linux Enterprise Server for SAP applications 16.0","openSUSE:Leap 16.0"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Information disclosure in GNU SASL","id":"CVE-2026-56968","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux"],"type":"information_disclosure","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"Missing authorization in Android","id":"CVE-2026-56970"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Server 16.0","fixed":["2.2.1-160000.4.1"],"introduced":["0"],"last_affected":[],"package":"gsasl","purl":"pkg:rpm/suse/gsasl\u0026distro=SUSE%20Linux%20Enterprise%20Server%2016.0","source":"SUSE-SU-2026:22631-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP applications 16.0","fixed":["2.2.1-160000.4.1"],"introduced":["0"],"last_affected":[],"package":"gsasl","purl":"pkg:rpm/suse/gsasl\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20applications%2016.0","source":"SUSE-SU-2026:22631-1"},{"ecosystem":"openSUSE:Leap 16.0","fixed":["2.2.1-160000.4.1"],"introduced":["0"],"last_affected":[],"package":"gsasl","purl":"pkg:rpm/opensuse/gsasl\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2026:21303-1"}],"prev":{"headline":"Memory corruption in Android","id":"CVE-2026-56967"},"products":["GNU SASL"],"published":"2026-06-23","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-31","vendors":["GNU"]},"summary":"A crafted server can trigger memory disclosure in the GNU SASL NTLM client due to lack of sanitization, potentially exposing sensitive data.","url":"https://insights.sbomify.com/CVE-2026-56968/"}