{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-57053 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-57053 is a medium-severity vulnerability in GNU libidn, published on 23 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-57053 and fix it if it is affected.\n\nWhat it is: CVE-2026-57053 is a medium-severity vulnerability in GNU libidn, published on 23 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-57053 in the wild and no public exploit code.\n\nAffected product: GNU libidn. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-57053/ (Markdown: https://insights.sbomify.com/CVE-2026-57053/index.md)","id":"CVE-2026-57053","markdown":"https://insights.sbomify.com/CVE-2026-57053/index.md","name":"CVE-2026-57053","record":{"aliases":["DEBIAN-CVE-2026-57053","ECHO-f940-3352-dc67","GHSA-xpv7-vm32-p7wv","JLSEC-2026-667","MGASA-2026-0262","OESA-2026-2932","OESA-2026-2933","OESA-2026-2934","OESA-2026-2935","OESA-2026-2983","RHSA-2026:42125","SUSE-SU-2026:23621-1","SUSE-SU-2026:4000-1","SUSE-SU-2026:4081-1","UBUNTU-CVE-2026-57053","USN-8521-1","openSUSE-SU-2026:21758-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"GNU libidn library","requires_auth":"none","summary":"An out-of-bounds read in GNU libidn allows attackers to read uninitialized memory, potentially disclosing sensitive information.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"libidn","vendor":"gnu"}],"cvss":{"score":4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-1284","name":"Improper Validation of Specified Quantity in Input"}],"description":"GNU libidn before 1.44 is prone to out-of-bounds reads of uninitialized memory in the ToUnicode APIs because of mishandling in idna_to_unicode_internal. The affected code is not present in libidn2.","ecosystems":["Red Hat:hummingbird:1","SUSE:Linux Enterprise Module for Basesystem 15 SP7","SUSE:Linux Enterprise Server 16.0","SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5","SUSE:Linux Enterprise Server for SAP applications 16.0","openSUSE:Leap 16.0"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Information disclosure in libidn","id":"CVE-2026-57053","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":8,"n_references":2,"next":{"headline":"Junos OS: MX Series: Web filtering doesn't block specifically formatted URLs","id":"CVE-2026-57054"},"packages":[{"ecosystem":"Red Hat:hummingbird:1","fixed":["0:2.3.8-4.hum1"],"introduced":["0"],"last_affected":[],"package":"idn2","purl":"pkg:rpm/redhat/idn2","source":"RHSA-2026:42125"},{"ecosystem":"Red Hat:hummingbird:1","fixed":["0:2.3.8-4.hum1"],"introduced":["0"],"last_affected":[],"package":"libidn2","purl":"pkg:rpm/redhat/libidn2","source":"RHSA-2026:42125"},{"ecosystem":"Red Hat:hummingbird:1","fixed":["0:2.3.8-4.hum1"],"introduced":["0"],"last_affected":[],"package":"libidn2-devel","purl":"pkg:rpm/redhat/libidn2-devel","source":"RHSA-2026:42125"},{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP7","fixed":["1.34-150000.3.5.1"],"introduced":["0"],"last_affected":[],"package":"libidn","purl":"pkg:rpm/suse/libidn\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP7","source":"SUSE-SU-2026:4000-1"},{"ecosystem":"SUSE:Linux Enterprise Server 16.0","fixed":["1.43-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"libidn","purl":"pkg:rpm/suse/libidn\u0026distro=SUSE%20Linux%20Enterprise%20Server%2016.0","source":"SUSE-SU-2026:23621-1"},{"ecosystem":"SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5","fixed":["1.28-5.9.1"],"introduced":["0"],"last_affected":[],"package":"libidn","purl":"pkg:rpm/suse/libidn\u0026distro=SUSE%20Linux%20Enterprise%20Server%20LTSS%20Extended%20Security%2012%20SP5","source":"SUSE-SU-2026:4081-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP applications 16.0","fixed":["1.43-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"libidn","purl":"pkg:rpm/suse/libidn\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20applications%2016.0","source":"SUSE-SU-2026:23621-1"},{"ecosystem":"openSUSE:Leap 16.0","fixed":["1.43-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"libidn","purl":"pkg:rpm/opensuse/libidn\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2026:21758-1"}],"prev":{"headline":"Privilege escalation in Android","id":"CVE-2026-57042"},"products":["libidn"],"published":"2026-06-23","related":[{"cvss_score":7.5,"headline":"The stringprep_utf8_nfkc_normalize function in lib/nfkc.c in libidn before 1.33 allows context-dependent attackers to cause a denial of serv","id":"CVE-2016-6263","kev_date_added":null,"published":"2016-09-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-23","vendors":["GNU"]},"summary":"An out-of-bounds read in GNU libidn allows attackers to read uninitialized memory, potentially disclosing sensitive information.","url":"https://insights.sbomify.com/CVE-2026-57053/"}