# CVE-2026-57113: PraisonAI GitHub template cache path traversal allows outside-cache file write and directory deletion


- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** GHSA-f44v-7qgw-9gh9, PYSEC-2026-3509

## What is CVE-2026-57113?

CVE-2026-57113 is a high-severity vulnerability in MervinPraison PraisonAI, published on 23 Oct 2026. 

### Official description

PraisonAI is a multi-agent teams system. From version 2.6.0 to before version 4.6.59, PraisonAI's template loader accepts GitHub template URIs with refs, for example github:owner/repo/template@v1.0.0. The resolver stores the user-controlled template path and ref verbatim, and the cache layer later joins those values into ~/.praison/cache/templates/github/<owner>/<repo>/<template>/<ref> without normalizing each segment or checking that the final path remains inside the template cache root. A crafted ref such as ../../../../../../outside-delete-target therefore escapes the cache directory. The first load can write .cache_meta.json outside the cache. If the normal cache hierarchy for the same owner/repo/template has already been created, the same path reaches shutil.rmtree(cache_path) and removes an attacker-selected outside directory before replacing it with cache metadata. This issue has been patched in version 4.6.59.

Weakness: CWE-73 (External Control of File Name or Path), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-57113?

3 open source packages ship an affected version, including praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | From 2.6.0 | 4.6.59 |
| `praisonai` | PyPI | From 2.6.0 | 4.6.59 |
| `praisonai` | PyPI | From 2.6.0 | 4.6.59 |

## How do I fix CVE-2026-57113?

Upgrade praisonai to 4.6.59 or later.

## Is CVE-2026-57113 being exploited?

There is no known exploitation of CVE-2026-57113 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57113 and fix it if it is affected.

What it is: CVE-2026-57113 is a high-severity vulnerability in MervinPraison PraisonAI, published on 23 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-57113 in the wild and no public exploit code.

Affected packages and fixed versions:
- praisonai (PyPI): affected from 2.6.0; fixed in 4.6.59
- praisonai (PyPI): affected from 2.6.0; fixed in 4.6.59
- praisonai (PyPI): affected from 2.6.0; fixed in 4.6.59

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57113/ (Markdown: https://insights.sbomify.com/CVE-2026-57113/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57113
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57113
- OSV: https://osv.dev/vulnerability/CVE-2026-57113

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57113/
Summaries are generated and may contain mistakes; the official description above is the record.
