# CVE-2026-57116: PraisonAI: AgentOS remains unauthenticated after GHSA-pm96 patched version and allows remote agent invocation


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-892r-p3jq-jp24, PYSEC-2026-3507

## What is CVE-2026-57116?

CVE-2026-57116 is a critical vulnerability in MervinPraison PraisonAI, published on 23 Oct 2026. 

### Official description

PraisonAI is a multi-agent teams system. From version 4.2.1 to before version 4.6.59, PraisonAI's AgentOS FastAPI deployment surface remains unauthenticated in current main and in releases after the published patched version for GHSA-pm96-6xpr-978x / CVE-2026-40151. The chat route directly calls agent.chat(request.message). No-auth and wrong-bearer requests both execute the deployed agent. This is broader than passive metadata disclosure. In any deployment where AgentOS wraps agents with tools, private context, memory, API integrations, or cost-bearing model calls, an unauthenticated reachable client can drive those agents. This issue has been patched in version 4.6.59.

Weakness: CWE-862 (Missing Authorization), CWE-306 (Missing Authentication for Critical Functionality), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-57116?

3 open source packages ship an affected version, including praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | From 4.2.1 | 4.6.59 |
| `praisonai` | PyPI | From 4.2.1 | 4.6.59 |
| `praisonai` | PyPI | From 4.2.1 | 4.6.59 |

## How do I fix CVE-2026-57116?

Upgrade praisonai to 4.6.59 or later.

## Is CVE-2026-57116 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57116 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57116 and fix it if it is affected.

What it is: CVE-2026-57116 is a critical vulnerability in MervinPraison PraisonAI, published on 23 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57116 exists.

Affected packages and fixed versions:
- praisonai (PyPI): affected from 4.2.1; fixed in 4.6.59
- praisonai (PyPI): affected from 4.2.1; fixed in 4.6.59
- praisonai (PyPI): affected from 4.2.1; fixed in 4.6.59

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57116/ (Markdown: https://insights.sbomify.com/CVE-2026-57116/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57116
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57116
- OSV: https://osv.dev/vulnerability/CVE-2026-57116

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57116/
Summaries are generated and may contain mistakes; the official description above is the record.
