# CVE-2026-57117: PraisonAI: Compute-bridged file tools allow shell command injection


- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** GHSA-w6h2-fr4q-xvxv, PYSEC-2026-3522

## What is CVE-2026-57117?

CVE-2026-57117 is a high-severity vulnerability in MervinPraison PraisonAI, published on 23 Oct 2026. 

### Official description

PraisonAI is a multi-agent teams system. From version 4.6.10 to before version 4.6.59, LocalManagedAgent / SandboxedAgent compute bridging wraps read_file, list_files, and write_file when a compute provider is attached. The bridge converts those file operations into shell command strings using raw path arguments, then sends those strings to shell-backed compute providers. An attacker who can influence a file-tool path argument can break out of the quoted path and execute arbitrary shell commands in the compute environment. With compute="local", commands execute through the local subprocess compute provider on the host. With Docker, commands execute in the container. This issue has been patched in version 4.6.59.

Weakness: CWE-863 (Incorrect Authorization), CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-57117?

3 open source packages ship an affected version, including praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | From 4.6.10 | 4.6.59 |
| `praisonai` | PyPI | From 4.6.10 | 4.6.59 |
| `praisonai` | PyPI | From 4.6.10 | 4.6.59 |

## How do I fix CVE-2026-57117?

Upgrade praisonai to 4.6.59 or later.

## Is CVE-2026-57117 being exploited?

There is no known exploitation of CVE-2026-57117 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57117 and fix it if it is affected.

What it is: CVE-2026-57117 is a high-severity vulnerability in MervinPraison PraisonAI, published on 23 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-57117 in the wild and no public exploit code.

Affected packages and fixed versions:
- praisonai (PyPI): affected from 4.6.10; fixed in 4.6.59
- praisonai (PyPI): affected from 4.6.10; fixed in 4.6.59
- praisonai (PyPI): affected from 4.6.10; fixed in 4.6.59

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57117/ (Markdown: https://insights.sbomify.com/CVE-2026-57117/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57117
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57117
- OSV: https://osv.dev/vulnerability/CVE-2026-57117

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57117/
Summaries are generated and may contain mistakes; the official description above is the record.
