# CVE-2026-57121: PraisonAI: Missing ownership check on DELETE endpoints allows members to delete others' content in Platform API


- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** GHSA-rh39-9c67-59mh, PYSEC-2026-3526

## What is CVE-2026-57121?

CVE-2026-57121 is a high-severity vulnerability in MervinPraison PraisonAI, published on 23 Oct 2026. 

### Official description

PraisonAI is a multi-agent teams system. From version 0.1.4 to before version 0.1.5 in praisonai-platform, a workspace member can permanently delete any resource — projects, agents, issues, labels, issue dependencies, and issue-label attachments — created by the workspace owner or other members. All six content DELETE endpoints enforce workspace membership but perform no ownership or role check. A single malicious or compromised member account can wipe an entire workspace's content irreversibly. This issue has been patched in version 0.1.5.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-57121?

3 open source packages ship an affected version, including praisonai-platform.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai-platform` | PyPI | From 0.1.4 | 0.1.6 |
| `praisonai-platform` | PyPI | From 0.1.4 | 0.1.6 |
| `praisonai-platform` | PyPI | From 0.1.4 | 0.1.6 |

## How do I fix CVE-2026-57121?

Upgrade praisonai-platform to 0.1.6 or later.

## Is CVE-2026-57121 being exploited?

There is no known exploitation of CVE-2026-57121 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57121 and fix it if it is affected.

What it is: CVE-2026-57121 is a high-severity vulnerability in MervinPraison PraisonAI, published on 23 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-57121 in the wild and no public exploit code.

Affected packages and fixed versions:
- praisonai-platform (PyPI): affected from 0.1.4; fixed in 0.1.6
- praisonai-platform (PyPI): affected from 0.1.4; fixed in 0.1.6
- praisonai-platform (PyPI): affected from 0.1.4; fixed in 0.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57121/ (Markdown: https://insights.sbomify.com/CVE-2026-57121/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57121
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57121
- OSV: https://osv.dev/vulnerability/CVE-2026-57121

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57121/
Summaries are generated and may contain mistakes; the official description above is the record.
