# CVE-2026-57124: PraisonAI UI MCP connect endpoint allows unauthenticated local command execution

> Unauthenticated attackers can execute arbitrary local commands via the MCP connect endpoint in PraisonAI UI due to missing authentication and input validation.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-p75f-6fp4-p57w, PYSEC-2026-3517

## What is CVE-2026-57124?

CVE-2026-57124 is a critical command injection vulnerability in MervinPraison PraisonAI, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PraisonAI is a multi-agent teams system. Prior to 4.6.59, the default UI host applications expose POST /api/mcp/connect without mandatory authentication and accept caller-controlled command and args values that PraisonAIUI passes to StdioMCPClient to start a local process. Because the UI commands bind to 0.0.0.0 by default, a reachable unauthenticated client can execute commands as the UI service account even when the MCP handshake later fails. This vulnerability is fixed in 4.6.59.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-57124?

3 open source packages ship an affected version, including praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | All versions | 4.6.59 |
| `praisonai` | PyPI | All versions | 4.6.59 |
| `praisonai` | PyPI | All versions | 4.6.59 |

## How do I fix CVE-2026-57124?

Upgrade praisonai to 4.6.59 or later.

## Is CVE-2026-57124 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57124 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57124 and fix it if it is affected.

What it is: CVE-2026-57124 is a critical command injection vulnerability in MervinPraison PraisonAI, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57124 exists.

Affected packages and fixed versions:
- praisonai (PyPI): affected all versions; fixed in 4.6.59
- praisonai (PyPI): affected all versions; fixed in 4.6.59
- praisonai (PyPI): affected all versions; fixed in 4.6.59

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57124/ (Markdown: https://insights.sbomify.com/CVE-2026-57124/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57124
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57124
- OSV: https://osv.dev/vulnerability/CVE-2026-57124

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57124/
Summaries are generated and may contain mistakes; the official description above is the record.
